Merge branch 'org.openembedded.dev' of git+ssh://git@git.openembedded.org/openembedde...
[openembedded.git] / recipes / webkit / webkit-gtk_svn.bb
index 3c7ec06..64c031d 100644 (file)
@@ -3,7 +3,7 @@ DEPENDS = "enchant gtk-doc-native gtk-doc gnome-keyring libsoup-2.4 curl icu lib
 
 SRCREV_FORMAT = "webcore-rwebkit"
 
-PV = "1.1.6+svnr${SRCREV}"
+PV = "1.1.15+svnr${SRCREV}"
 
 SRC_URI = "\
   svn://svn.webkit.org/repository/webkit/trunk/;module=JavaScriptCore;proto=http \
@@ -17,7 +17,6 @@ SRC_URI = "\
   file://Makefile.shared \
   file://autogen.sh \
   file://configure.ac \
-  file://symbols.filter \
   file://GNUmakefile.am \
   file://gtk-doc.make \
  "
@@ -33,7 +32,9 @@ EXTRA_OECONF = "\
                 --enable-svg \
                 --enable-icon-database=yes \
                 --with-http-backend=soup \
-               "
+#                --with-unicode-backend=glib \
+                --with-libsoup-gnome=yes \
+"
 
 EXTRA_AUTORECONF = " -I autotools "
 
@@ -54,7 +55,7 @@ do_compile_prepend() {
             ${BUILD_CXX} dftables.cpp -o dftables -I. -I../wtf
         fi
         cp dftables ${S}/WebKitBuilds/Debug/JavaScriptCore/pcre/tmp/
-        cp dftables ${S}/Programs/        
+        cp dftables ${S}/Programs/
        cd ${S}
 }
 
@@ -67,5 +68,5 @@ FILES_${PN}launcher = "${bindir}/GtkLauncher"
 FILES_${PN}launcher-dbg = "${bindir}/.debug/GtkLauncher"
 FILES_libjavascriptcore = "${libdir}/libJavaScriptCore.so.*"
 FILES_${PN}-webinspector = "${datadir}/webkit-1.0/webinspector/"
-FILES_${PN} += "${datadir}/webkit-1.0/resources/error.html"
+FILES_${PN} += "${datadir}/webkit-1.0/resources/error.html ${datadir}/webkit-1.0/images"