libsdl-mixer 1.2.11: Move MP3 support to inside a check for ENTERPRISE_DISTRO so...
[openembedded.git] / recipes / libsdl / libsdl-mixer_1.2.11.bb
index d6c9c69..08127f6 100644 (file)
@@ -4,7 +4,7 @@ PRIORITY = "optional"
 DEPENDS = "virtual/libsdl flac libmikmod libvorbis libmad"
 LICENSE = "LGPL"
 
-PR = "r2"
+PR = "r3"
 
 SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${PV}.tar.gz \
            file://fix-flac-madness.diff;patch=1"
@@ -15,12 +15,18 @@ export SDL_CONFIG = "${STAGING_BINDIR_CROSS}/sdl-config"
 
 inherit autotools_stage
 
-# Although we build SMPEG lets not use it as it is pointless in the embedded space.
-
-# Add support for runtime linking with libmad so we can use that for fixed point MP3 decoding.
 # Add support for runtime linking with libtremor so we can use that for fixed point OGG Vorbis decoding.
+EXTRA_OECONF += " --enable-music-ogg --enable-music-ogg-tremor "
+
+# If we are not building an ENTERPRISE_DISTRO...
+# Add support for runtime linking with libmad so we can use that for fixed point MP3 decoding 
+# and disable SMPEG floating point MP3
+
+# If we are using an ENTERPRISE_DISTRO just disable all MP3 support.
 
-EXTRA_OECONF = "--disable-music-mp3 --enable-music-ogg --enable-music-ogg-tremor --enable-music-mp3-mad-gpl"
+EXTRA_OECONF += " \
+                ${@base_conditional('ENTERPRISE_DISTRO', '1', ' --disable-music-mp3', ' --disable-music-mp3 --enable-music-mp3-mad-gpl ', d)} \
+"
 
 do_compile() {
        # Override SDL_LIBS to include a linker rpath so the linker