libgcrypt: update to 1.4.6
[openembedded.git] / recipes / icu / icu_3.6.bb
index 1dbdf94..020a4e8 100644 (file)
@@ -1,14 +1,16 @@
 require icu-3.6.inc
 
 DEPENDS += "icu-native"
-PR = "r4"
+PR = "${INC_PR}.1"
 
-SRC_URI += "file://use-g++-for-linking.patch;patch=1"
+SRC_URI += "file://use-g++-for-linking.patch;patch=1 \
+            file://rematch-gcc-bug.patch;patch=1"
 
 do_configure_append() {
-        for i in */Makefile */*.inc */*/Makefile */*/*.inc ; do
+        for i in */Makefile */*.inc */*/Makefile */*/*.inc icudefs.mk ; do
                sed -i -e 's:$(INVOKE) $(BINDIR)/:$(INVOKE) :g' $i 
                sed -i -e 's:$(BINDIR)/::g' $i 
+               sed -i -e 's:LD_LIBRARY_PATH:LD_LIBRARY_PATH_FAKE:g' $i
         done
        sed -i -e 's:$(BINDIR)/::g' extra/uconv/pkgdata.inc || true
        sed -i -e 's:$(BINDIR)/::g' extra/uconv/pkgdata.inc.in || true
@@ -36,9 +38,11 @@ do_stage() {
         autotools_stage_all
 }
 
-# We need to append this so it runs *after* binconfig.do_stage
-do_stage_append() {
-        sed -i -e s:^prefix=:prefix=\"${STAGING_DIR_TARGET}/usr\": ${STAGING_BINDIR_CROSS}/icu-config
+SYSROOT_PREPROCESS_FUNCS += "icu_sysroot_preprocess"
+
+# We need to append this so it runs *after* binconfig's preprocess function
+icu_sysroot_preprocess () {
+        sed -i -e s:^prefix=:prefix=\"${STAGING_DIR_TARGET}/usr\": ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}/icu-config
 }