xfce4-battery-plugin: tune the pandora hack
[openembedded.git] / recipes / hostap / hostap-daemon_0.6.9.bb
index 0b7a192..01830c5 100644 (file)
@@ -3,32 +3,23 @@ HOMEPAGE = "http://hostap.epitest.fi"
 SECTION = "kernel/userland"
 PRIORITY = "optional"
 LICENSE = "GPL"
-DEPENDS = "libnl openssl ${@base_contains("COMBINED_FEATURES", "pci", "madwifi-ng", "",d)}"
-PR = "r0"
+DEPENDS = "libnl openssl"
+PR = "r2"
 
 DEFAULT_PREFERENCE = "-1"
 
-#we introduce MY_ARCH to get 'armv5te' as arch instead of the misleading 'arm' on armv5te builds
-MY_ARCH := "${PACKAGE_ARCH}"
-PACKAGE_ARCH = "${@base_contains('COMBINED_FEATURES', 'pci', '${MACHINE_ARCH}', '${MY_ARCH}', d)}"
-
 SRC_URI = "http://hostap.epitest.fi/releases/hostapd-${PV}.tar.gz \
+       file://ldflags.patch;patch=1 \
        file://defconfig \
        file://init"
 
 S = "${WORKDIR}/hostapd-${PV}/hostapd"
 
-export HAS_PCI = "${@base_contains('COMBINED_FEATURES', 'pci', 1, 0,d)}"
-
 inherit update-rc.d
 INITSCRIPT_NAME=hostapd
 
 do_configure() {
        install -m 0644 ${WORKDIR}/defconfig ${S}/.config
-       if [ "x$HAS_PCI" = "x1" ] ; then
-               echo "CONFIG_DRIVER_MADWIFI=y" >> .config
-               echo "CFLAGS += -I${STAGING_INCDIR}/madwifi-ng" >> .config
-       fi
 }
 
 do_compile() {