gtk-engines: remove hard-coded paths. Closes 2364.
[openembedded.git] / packages / gtk-engines / gtk-smooth-engine_0.5.8.bb
index 95a8d87..28888c4 100644 (file)
@@ -1,11 +1,22 @@
-PR = "r0"
-LICENSE = "LGPL"
-SECTION = "x11/base"
 DESCRIPTION = "GTK theme engine Smooth"
+SECTION = "x11/base"
+PRIORITY = "optional"
+LICENSE = "LGPL"
 DEPENDS = "gtk+"
-
-FILES_${PN} = "${libdir}/gtk-2.0/2.4.0/engines/libsmooth.so"
+PR = "r1"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/smooth-engine/${PN}-${PV}.tar.gz"
 
 inherit autotools pkgconfig
+
+python populate_packages_prepend() {
+       import os.path
+
+       engines_ver = ['gtk-2.0/', gtkbinver_find(d), '/engines']
+
+       engines_root = os.path.join(bb.data.getVar('libdir', d, 1), ''.join(engines_ver))
+       themes_root = os.path.join(bb.data.getVar('datadir', d, 1), "themes")
+
+       do_split_packages(d, engines_root, '^lib(.*)\.so$', 'gtk-engine-%s', 'GTK %s theme engine', extra_depends='')
+       do_split_packages(d, themes_root, '(.*)', 'gtk-theme-%s', 'GTK theme %s', allow_dirs=True, extra_depends='')
+}