sg3-utils: add newer buildable version
[openembedded.git] / recipes / xorg-xserver / xserver-kdrive_1.1.0.bb
1 LICENSE = "MIT"
2 DEPENDS = "tslib xproto libxdmcp xextproto xtrans libxau virtual/libx11 libxext libxrandr fixesproto damageproto libxfont resourceproto compositeproto calibrateproto recordproto videoproto scrnsaverproto"
3
4 PROVIDES = "virtual/xserver"
5 PACKAGES =+ "xserver-kdrive-fbdev xserver-kdrive-fake xserver-kdrive-xephyr"
6 SECTION = "x11/base"
7 DESCRIPTION = "X server from freedesktop.org"
8 DESCRIPTION_xserver-kdrive-fbdev = "X server from freedesktop.org, supporting generic framebuffer devices"
9 DESCRIPTION_xserver-kdrive-fake = "Fake X server"
10 DESCRIPTION_xserver-kdrive-xephyr = "X server in an X window"
11
12 PE = "1"
13 PR = "r2"
14
15 FILES_${PN} = "${libdir}/xserver"
16 FILES_xserver-kdrive-fbdev = "${bindir}/Xfbdev"
17 FILES_xserver-kdrive-fake = "${bindir}/Xfake"
18 FILES_xserver-kdrive-xephyr = "${bindir}/Xephyr"
19
20 RDEPENDS_xserver-kdrive-fbdev = "${PN}"
21 RDEPENDS_xserver-kdrive-fake = "${PN}"
22 RDEPENDS_xserver-kdrive-xephyr = "${PN}"
23
24 SRC_URI = "${XORG_MIRROR}/individual/xserver/xorg-server-1.1.0.tar.bz2 \
25         file://kmode.patch;patch=1 \
26         file://disable-apm.patch;patch=1 \
27         file://no-serial-probing.patch;patch=1 \
28         file://kdrive-evdev.patch;patch=1  \
29         file://kdrive-use-evdev.patch;patch=1  \
30         file://fbdev-not-fix.patch;patch=1  \
31         file://enable-builtin-fonts.patch;patch=1 \
32         file://optional-xkb.patch;patch=1 \
33         file://disable-xf86-dga-xorgcfg.patch;patch=1 \
34         file://enable-tslib.patch;patch=1 \
35         file://xcalibrate.patch;patch=1 \
36         file://xfbdev-fb-opt.patch;patch=1 \
37         file://hide-cursor-and-ppm-root.patch;patch=1 \
38         file://report-correct-randr10.patch;patch=1"
39
40 SRC_URI_append_mnci   = " file://onlyfb.patch;patch=1"
41 SRC_URI_append_poodle = " file://xserver-kdrive-poodle.patch;patch=1"
42 SRC_URI_append_qemux86 = " file://xserver-kdrive-poodle.patch;patch=1"
43 PACKAGE_ARCH_poodle = "poodle"
44
45 S = "${WORKDIR}/xorg-server-1.1.0"
46
47 inherit autotools pkgconfig 
48
49 EXTRA_OECONF = "--enable-composite --enable-kdrive \
50                 --disable-dga --disable-dri --disable-xinerama \
51                 --disable-xf86misc --disable-xf86vidmode \
52                 --disable-xorg --disable-xorgcfg \
53                 --disable-dmx \ 
54                 --disable-xkb --disable-xnest --disable-xvfb \
55                 --disable-xevie --disable-xprint --disable-xtrap \
56                 --with-default-font-path=built-ins \
57                 ac_cv_file__usr_share_sgml_X11_defs_ent=no"
58
59 do_configure_prepend() {
60     sed -i -e 's/tslib-0.0/tslib-1.0/' ${S}/configure.ac
61 }