thunar: avoid trash polling
[openembedded.git] / recipes / xorg-proto / xextproto-70-includes_7.0.5.bb
1 # Build of xserver-kdrive is not possible with xextproto >= 7.1.
2 # This package allows to install old 7.0 includes in parallel.
3 FILESPATH = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/xextproto-7.0:${@os.path.dirname(bb.data.getVar('FILE',d,1))}/xextproto:${@os.path.dirname(bb.data.getVar('FILE',d,1))}/files"
4 PR_append = ".1"
5
6 BPN = "xextproto"
7
8 require xextproto_7.0.5.bb
9
10 XORG_PN = "xextproto"
11 EXTRA_OECONF += "--includedir=${includedir}/xextproto-70"
12
13 do_install_append() {
14         rm -r ${D}${libdir}
15 }
16 # xorg-proto-common.inc would stage all. We need to overwrite it.
17 do_stage() {
18         autotools_stage_includes
19 }
20 # No, we really do not want to install .pc file and overwrite newer one:
21 pkgconfig_sysroot_preprocess() {
22 }