libgcrypt: restore BBCLASSEXTEND
[openembedded.git] / recipes / xorg-lib / pixman_0.32.6.bb
1 SUMMARY = "Pixman: Pixel Manipulation library"
2
3 DESCRIPTION = "Pixman provides a library for manipulating pixel regions \
4 -- a set of Y-X banded rectangles, image compositing using the \
5 Porter/Duff model and implicit mask generation for geometric primitives \
6 including trapezoids, triangles, and rectangles."
7
8 DEFAULT_PREFERENCE_angstrom = "2"
9
10 require xorg-lib-common.inc
11
12 LICENSE = "MIT MIT-style PD"
13 LIC_FILES_CHKSUM = "file://COPYING;md5=14096c769ae0cbb5fcb94ec468be11b3 \
14                     file://pixman/pixman-matrix.c;endline=25;md5=ba6e8769bfaaee2c41698755af04c4be \
15                     file://pixman/pixman-arm-neon-asm.h;endline=24;md5=9a9cc1e51abbf1da58f4d9528ec9d49b \
16                    "
17 DEPENDS += "zlib libpng"
18 BBCLASSEXTEND = "native nativesdk"
19
20 PE = "1"
21
22 IWMMXT = "--disable-arm-iwmmxt"
23 LOONGSON_MMI = "--disable-loongson-mmi"
24 NEON = " --disable-arm-neon "
25 NEON_armv7a = " "
26 NEON_armv7a-vfp-neon = " "
27
28 EXTRA_OECONF = "--disable-gtk ${IWMMXT} ${LOONGSON_MMI} ${NEON}"
29 EXTRA_OECONF_virtclass-native = "--disable-gtk"
30
31 SRC_URI += "\
32 #        file://0001-ARM-qemu-related-workarounds-in-cpu-features-detecti-0-32.patch;patch=1 \
33         file://0001-Generic-C-implementation-of-pixman_blt-with-overlapp-0-32.patch;patch=1 \
34         file://0004-Support-of-overlapping-src-dst-for-pixman_blt_neon-0-32.patch;patch=1 \
35 "
36
37 SRC_URI[archive.md5sum] = "8a9e8f14743a39cf303803f369c1f344"
38 SRC_URI[archive.sha256sum] = "201fc0d7d6bc0017496f2bd27b3ca14224aea0df6b624c5ee2dc0307a4ff14a4"