xfwm4-themes 4.6.0: Refactor recipe to clean up the production of the theme packages...
[openembedded.git] / recipes / xfce-base / xfwm4-themes_4.6.0.bb
1 # xfwm4-themes OE build file
2
3 SECTION = "x11/wm"
4 PR = "r3"
5
6 DEPENDS = "xfwm4 libglade libxml2"
7 RDEPENDS = "xfwm4 libglade libxml2"
8
9 inherit xfce46
10
11 SRC_URI = "http://mocha.xfce.org/archive/src/art/xfwm4-themes/4.6/xfwm4-themes-${PV}.tar.bz2"
12
13 PACKAGES_DYNAMIC = "xfwm4-theme-*"
14
15 python populate_packages_prepend () {
16         themedir = bb.data.expand('${datadir}/themes', d)
17         do_split_packages(d, themedir, '^(.*)', 'xfwm4-theme-%s', 'Xfce4 Window Manager theme - %s', allow_dirs=True)
18
19         metapkg = "xfwm4-themes"
20         bb.data.setVar('ALLOW_EMPTY_' + metapkg, "1", d)
21         bb.data.setVar('FILES_' + metapkg, "", d)
22         blacklist = [ 'xfwm4-themes', 'xfwm4-themes-dev', 'xfwm4-themes-doc', 'xfwm4-themes-dbg', 'xfwm4-themes-static', 'xfwm4-themes-locale' ]
23         recipe_rdepends = bb.data.getVar('RDEPENDS', d, 1).split()
24         metapkg_rdepends = []
25         packages = bb.data.getVar('PACKAGES', d, 1).split()
26         for pkg in packages[1:]:
27                 if not pkg in blacklist and not pkg in metapkg_rdepends:
28                         bb.data.setVar('RDEPENDS_' + pkg, ' '.join(recipe_rdepends), d)
29                         metapkg_rdepends.append(pkg)
30         metapkg_rdepends.extend(recipe_rdepends)
31         bb.data.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends), d)
32         bb.data.setVar('DESCRIPTION_' + metapkg, 'Xfce4 Window Manager extra themes - Meta package', d)
33 }