libgcrypt: restore BBCLASSEXTEND
[openembedded.git] / recipes / xfce-base / exo_0.3.107.bb
1 DESCRIPTION="Xfce extensions and framework library with session management support"
2 DEPENDS = "libxfce4util hal liburi-perl-native python-native cairo"
3 SECTION = "x11"
4 PR = "r2"
5
6 inherit xfce46 python-dir
7
8 XFCE_VERSION = "4.6.2"
9
10 SRC_URI += " \
11     file://exo-no-tests.patch;patch=1 \
12     file://configure.patch;patch=1 \
13     file://glib_compat.patch;patch=1 \
14 "
15
16 # Note: Python checking is broken
17 do_configure_prepend() {
18         sed -i -e s:'`$PKG_CONFIG --variable=defsdir pygtk-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/defs\":g ${S}/configure.in
19 }
20
21 FILES_${PN} += "${datadir}/xfce4/ \
22                 ${PYTHON_SITEPACKAGES_DIR}/* \
23                 ${prefix}/share/pygtk/2.0/defs/exo-0.3/exo.defs \
24 "
25
26 FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/*/.debug/*"
27
28 SRC_URI[md5sum] = "3a92cca0c99ee940db4410891c9e8498"
29 SRC_URI[sha256sum] = "0a12ac124bad67c8de7135f7052641239ed640884a71612930f99c425bede2a3"