libgcrypt: restore BBCLASSEXTEND
[openembedded.git] / recipes / x-load / x-load_git.bb
1 require x-load.inc
2
3 DEFAULT_PREFERENCE_am3517-evm = "-1"
4 DEFAULT_PREFERENCE_omap3-pandora = "-1"
5
6 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/x-load-git/${MACHINE}"
7
8 SRCREV = "319b26586fafb86f919f514bcd175838aaab96b3"
9 SRCREV_beagleboard = "1c9276af4d6a5b7014a7630a1abeddf3b3177563"
10
11 PV = "1.42+${PR}+gitr${SRCREV}"
12 PV_beagleboard = "1.44+${PR}+gitr${SRCREV}"
13 PR ="r9"
14 PE = "1"
15
16 SRC_URI = "git://gitorious.org/x-load-omap3/mainline.git;branch=master;protocol=git"
17
18 SRC_URI_append_beagleboard = " \
19                               file://name.patch;patch=1 \
20                              "
21
22 SRC_URI_append_omap3-touchbook = " \
23                               file://name.patch;patch=1 \
24                               file://screen-off.patch;patch=1 \
25                              "
26
27
28 SRC_URI_append_am3517-evm = " \
29                                  file://xload-shiva.diff;patch=1 \
30 "
31
32 SRC_URI_omapzoom2 = "git://dev.omapzoom.org/pub/scm/bootloader/x-loader.git;protocol=git \
33                      http://www.xora.org.uk/~dp/oe/zoom2.u-boot.git_78e778e0ea884306841c6499851a1e35177d81d0.tar.gz;name=uboot"
34 SRCREV_omapzoom2 = "599c6cb87ee0c01fd6632b24f6d7e0a2b3ea5d0a"
35
36 SRC_URI_omapzoom36x = "git://dev.omapzoom.org/pub/scm/bootloader/x-loader.git;protocol=git \
37                        http://www.xora.org.uk/~dp/oe/zoom2.u-boot.git_78e778e0ea884306841c6499851a1e35177d81d0.tar.gz;name=uboot"
38 SRCREV_omapzoom36x = "251d92815500143aefdbe3b3558a0ce6daeaebdc"
39
40 SRC_URI[uboot.md5sum] = "e68b30714d22ce2f926d2dd19f94a2be"
41 SRC_URI[uboot.sha256sum] = "e7e5c87d939cc4c1f14d17ea0814b0bed97021c7afca3ef9053c896c2b5bdd6f"
42
43 S = "${WORKDIR}/git"
44
45 PACKAGE_ARCH = "${MACHINE_ARCH}"