webkit-gtk: fix PV
[openembedded.git] / recipes / webkit / webkit-gtk_svn.bb
1 DESCRIPTION = "WebKit browser engine, GTK+ edition"
2 DEPENDS = "gnome-keyring libsoup-2.4 curl icu libxml2 cairo libxslt libxt libidn gnutls gtk+ gstreamer gst-plugins-base gnome-vfs bison-native flex-native gperf-native perl-native sqlite3"
3
4 SRCREV_FORMAT = "webcore-rwebkit"
5
6 PV = "1.1.3+svnr${SRCREV}"
7
8 SRC_URI = "\
9   svn://svn.webkit.org/repository/webkit/trunk/;module=JavaScriptCore;proto=http \
10   svn://svn.webkit.org/repository/webkit/trunk/;module=JavaScriptGlue;proto=http \
11   svn://svn.webkit.org/repository/webkit/trunk/;module=WebCore;proto=http;name=webcore \
12   svn://svn.webkit.org/repository/webkit/trunk/;module=WebKit;proto=http;name=webkit \
13   svn://svn.webkit.org/repository/webkit/trunk/;module=WebKitLibraries;proto=http \
14   svn://svn.webkit.org/repository/webkit/trunk/;module=WebKitTools;proto=http \
15   svn://svn.webkit.org/repository/webkit/trunk/;module=autotools;proto=http \
16   file://Makefile \
17   file://Makefile.shared \
18   file://autogen.sh \
19   file://configure.ac \
20   file://symbols.filter \
21   file://GNUmakefile.am \
22  "
23
24 S = "${WORKDIR}/"
25
26 inherit autotools pkgconfig lib_package
27
28 export BISON="${STAGING_BINDIR_NATIVE}/bison"
29 ARM_INSTRUCTION_SET = "arm"
30 EXTRA_OECONF = "\
31                 --enable-debug=no \
32                 --enable-svg \
33                 --enable-icon-database=yes \
34                 --with-http-backend=soup \
35                "
36 EXTRA_AUTORECONF = " -I autotools "
37
38 # Dolt gets used on x86 and ppc and hardcodes 'libtool'
39 do_configure_append() {
40         cp ${TARGET_PREFIX}libtool libtool || true
41 }
42
43 do_compile_prepend() {
44         mkdir -p ${S}/WebKitBuilds/Debug/JavaScriptCore/pcre/tmp/
45         mkdir -p ${S}/Programs/
46         cd ${S}/JavaScriptCore/pcre
47         if test -e dftables.c
48         then
49             ${BUILD_CC} dftables.c -o dftables -I. -I../wtf
50         elif test -e dftables.cpp
51         then
52             ${BUILD_CXX} dftables.cpp -o dftables -I. -I../wtf
53         fi
54         cp dftables ${S}/WebKitBuilds/Debug/JavaScriptCore/pcre/tmp/
55         cp dftables ${S}/Programs/        
56         cd ${S}
57 }
58
59 do_stage() {
60         autotools_stage_all
61 }
62
63 PACKAGES =+ "${PN}-webinspector ${PN}launcher-dbg ${PN}launcher libjavascriptcore"
64 FILES_${PN}launcher = "${bindir}/GtkLauncher"
65 FILES_${PN}launcher-dbg = "${bindir}/.debug/GtkLauncher"
66 FILES_libjavascriptcore = "${libdir}/libJavaScriptCore.so.*"
67 FILES_${PN}-webinspector = "${datadir}/webkit-1.0/webinspector/"
68
69