Merge branch 'org.openembedded.dev' of git+ssh://git@git.openembedded.org/openembedde...
[openembedded.git] / recipes / webkit / webkit-gtk_svn.bb
1 DESCRIPTION = "WebKit browser engine, GTK+ edition"
2 DEPENDS = "enchant gtk-doc-native gtk-doc gnome-keyring libsoup-2.4 curl icu libxml2 cairo libxslt libxt libidn gnutls gtk+ gstreamer gst-plugins-base gnome-vfs bison-native flex-native gperf-native perl-native sqlite3"
3
4 SRCREV_FORMAT = "webcore-rwebkit"
5
6 PV = "1.1.15+svnr${SRCREV}"
7
8 SRC_URI = "\
9   svn://svn.webkit.org/repository/webkit/trunk/;module=JavaScriptCore;proto=http \
10   svn://svn.webkit.org/repository/webkit/trunk/;module=JavaScriptGlue;proto=http \
11   svn://svn.webkit.org/repository/webkit/trunk/;module=WebCore;proto=http;name=webcore \
12   svn://svn.webkit.org/repository/webkit/trunk/;module=WebKit;proto=http;name=webkit \
13   svn://svn.webkit.org/repository/webkit/trunk/;module=WebKitLibraries;proto=http \
14   svn://svn.webkit.org/repository/webkit/trunk/;module=WebKitTools;proto=http \
15   svn://svn.webkit.org/repository/webkit/trunk/;module=autotools;proto=http \
16   file://Makefile \
17   file://Makefile.shared \
18   file://autogen.sh \
19   file://configure.ac \
20   file://GNUmakefile.am \
21   file://gtk-doc.make \
22  "
23
24 S = "${WORKDIR}/"
25
26 inherit autotools pkgconfig lib_package
27
28 export BISON="${STAGING_BINDIR_NATIVE}/bison"
29 ARM_INSTRUCTION_SET = "arm"
30 EXTRA_OECONF = "\
31                 --enable-debug=no \
32                 --enable-svg \
33                 --enable-icon-database=yes \
34                 --with-http-backend=soup \
35 #                --with-unicode-backend=glib \
36                 --with-libsoup-gnome=yes \
37 "
38
39 EXTRA_AUTORECONF = " -I autotools "
40
41 # Dolt gets used on x86 and ppc and hardcodes 'libtool'
42 do_configure_append() {
43         cp ${TARGET_PREFIX}libtool libtool || true
44 }
45
46 do_compile_prepend() {
47         mkdir -p ${S}/WebKitBuilds/Debug/JavaScriptCore/pcre/tmp/
48         mkdir -p ${S}/Programs/
49         cd ${S}/JavaScriptCore/pcre
50         if test -e dftables.c
51         then
52             ${BUILD_CC} dftables.c -o dftables -I. -I../wtf
53         elif test -e dftables.cpp
54         then
55             ${BUILD_CXX} dftables.cpp -o dftables -I. -I../wtf
56         fi
57         cp dftables ${S}/WebKitBuilds/Debug/JavaScriptCore/pcre/tmp/
58         cp dftables ${S}/Programs/
59         cd ${S}
60 }
61
62 do_stage() {
63         autotools_stage_all
64 }
65
66 PACKAGES =+ "${PN}-webinspector ${PN}launcher-dbg ${PN}launcher libjavascriptcore"
67 FILES_${PN}launcher = "${bindir}/GtkLauncher"
68 FILES_${PN}launcher-dbg = "${bindir}/.debug/GtkLauncher"
69 FILES_libjavascriptcore = "${libdir}/libJavaScriptCore.so.*"
70 FILES_${PN}-webinspector = "${datadir}/webkit-1.0/webinspector/"
71 FILES_${PN} += "${datadir}/webkit-1.0/resources/error.html ${datadir}/webkit-1.0/images"
72