libgcrypt: restore BBCLASSEXTEND
[openembedded.git] / recipes / u-boot / u-boot-utils_1.2.0.bb
1 DESCRIPTION = "U-boot bootloader OS env. access tools"
2 SECTION = "bootloaders"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5 DEPENDS = "mtd-utils"
6 PR = "r9"
7
8 SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 \
9         file://fw_env.c.patch;patch=1 \
10         file://tools-Makefile.patch;patch=1 \
11         file://env-Makefile.patch;patch=1 \
12         file://fw_env.config"
13
14 S = "${WORKDIR}/u-boot-${PV}"
15
16 EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
17 TARGET_LDFLAGS = ""
18 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/u-boot-${PV}"
19
20 do_configure() {
21         :
22 }
23
24 do_compile () {
25         oe_runmake Sandpoint8240_config
26         oe_runmake tools
27 }
28
29 do_install () {
30         install -d      ${D}/sbin
31         install -d      ${D}${sysconfdir}
32         install -m 644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
33         install -m 755 ${S}/tools/env/fw_printenv ${D}/sbin/fw_printenv
34         install -m 755 ${S}/tools/env/fw_printenv ${D}/sbin/fw_setenv
35 }
36