xfce4-battery-plugin: tune the pandora hack
[openembedded.git] / recipes / u-boot / u-boot-mkimage_2015.01.bb
1 SUMMARY = "U-Boot bootloader image creation tool"
2 LICENSE = "GPLv2+"
3 LIC_FILES_CHKSUM = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
4 SECTION = "bootloader"
5
6 DEPENDS = "openssl"
7
8 # This revision corresponds to the tag "v2015.01"
9 # We use the revision in order to avoid having to fetch it from the
10 # repo during parse
11 SRCREV = "92fa7f53f1f3f03296f8ffb14bdf1baefab83368"
12
13 PV = "v2015.01+git${SRCPV}"
14
15 SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git \
16            file://gcc5.patch;patch=1 \
17            "
18
19 S = "${WORKDIR}/git"
20
21 EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" STRIP=true V=1'
22
23 do_compile () {
24         oe_runmake sandbox_defconfig
25         oe_runmake cross_tools NO_SDL=1
26 }
27
28 do_install () {
29         install -d ${D}${bindir}
30         install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
31         ln -sf uboot-mkimage ${D}${bindir}/mkimage
32 }
33
34 NATIVE_INSTALL_WORKS = "1"
35
36 BBCLASSEXTEND = "native nativesdk"