4042b9f2ab42375e298212e5867f27e5d150569f
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
1 DESCRIPTION = "Task file for the XFCE Pandora image"
2
3 # Don't forget to bump the PR if you change it.
4
5 PR = "r4"
6
7 inherit task
8
9 ANGSTROM_EXTRA_INSTALL ?= ""
10
11 APPS = " \
12   abiword \
13   claws-mail \
14   swfdec swfdec-gnome swfdec-mozilla \
15   firefox \
16   gnumeric \   
17   gimp \
18   networkmanager network-manager-applet \ 
19   synergy \
20   vnc \
21   x11vnc angstrom-x11vnc-xinit \
22   xmms \
23   xterm \
24 "
25
26 IM_CLIENT = " \
27   pidgin \
28   libpurple-protocol-msn \
29   libpurple-protocol-yahoo \
30   libpurple-protocol-icq \
31   libpurple-protocol-aim \
32 "
33
34 DISPMAN = " \
35   slim \
36 "
37
38 FONTS = " \
39   font-adobe-75dpi \
40   fontconfig fontconfig-utils font-util \
41   ttf-arphic-uming \
42   ttf-dejavu-common \
43   ttf-dejavu-sans \
44   ttf-dejavu-serif \
45   ttf-dejavu-sans-mono \
46   ttf-liberation-sans \
47   ttf-liberation-serif \
48   ttf-liberation-mono \
49   xorg-minimal-fonts \
50 "  
51
52 GNOME_APPS = " \
53   epiphany epiphany-extensions \
54   evince \  
55   gnome-games \
56   gnome-mplayer \
57   gcalctool \ 
58   gnome-bluetooth \     
59 "
60
61 GNOME_GTK = " \
62 #  hicolor-icon-theme \
63 #  gnome-icon-theme \
64 #  angstrom-gnome-icon-theme-enable \
65 "
66
67 GSTREAMER = " \
68   gst-ffmpeg \
69   gst-omapfb \
70   gst-plugin-pulse \
71   gst-plugins-base-meta \
72 #  gst-plugins-good-meta \
73   gst-plugins-bad-meta \
74 #  gst-plugins-ugly-meta \
75 "
76
77 ICON_THEME = " \
78   tango-icon-theme \
79   tango-icon-theme-enable \
80 "
81
82 PERL = " \
83   perl \
84   task-perl-module-all \
85   libnet-dbus-perl \
86   libxml-parser-perl \
87   libxml-twig-perl \
88 "
89
90 PULSEAUDIO = " \
91   pulseaudio-alsa-wrapper \
92   pulseaudio-esd-wrapper \
93   pulseaudio-module-gconf \
94   libasound-module-ctl-pulse \
95   libasound-module-pcm-pulse \
96 "
97
98 TOTEM = " \
99   totem \
100   totem-browser-plugin \
101   totem-plugin-bemused \
102   totem-plugin-gromit \
103   totem-plugin-media-player-keys \
104   totem-plugin-ontop \
105   totem-plugin-properties \
106   totem-plugin-screensaver \
107   totem-plugin-skipto \
108   totem-plugin-thumbnail \
109 "
110
111 XFCE46_BASE = " \
112   xfce4-dev-tools \
113   xfwm4 \
114   xfwm4-theme-default \
115   xfce-utils \  
116   xfce4-session \     
117   xfconf \
118   xfdesktop \
119   xfce4-panel \
120   \
121   gtk-xfce-engine \
122   \
123   xfce4-panel-plugin-actions \
124   xfce4-panel-plugin-clock \
125   xfce4-panel-plugin-iconbox \
126   xfce4-panel-plugin-launcher \
127   xfce4-panel-plugin-pager \
128   xfce4-panel-plugin-separator \
129   xfce4-panel-plugin-showdesktop \
130   xfce4-panel-plugin-systray \
131   xfce4-panel-plugin-tasklist \
132   xfce4-panel-plugin-windowlist \   
133   xfce4-settings \
134   xfce-terminal \
135   thunar \
136 "
137
138 XFCE46_EXTRAS = " \
139   xfce4-notifyd \
140   xfce4-mixer \
141   xfce4-appfinder \
142   xfprint \    
143   midori \
144   orage \
145   squeeze \
146   ristretto \
147   mousepad \ 
148   gigolo \
149 "
150
151 XFCE_THEMES = " \
152   xfwm4-theme-daloa \
153   xfwm4-theme-moheli \
154   xfwm4-theme-default-4.0 \
155   xfwm4-theme-default-4.2 \
156   xfwm4-theme-default-4.4 \
157   xfwm4-theme-kokodi \
158   xfwm4-theme-moheli \
159   xfwm4-theme-sassandra \
160   xfwm4-theme-stoneage \
161   xfwm4-theme-therapy \
162   xfwm4-theme-tyrex \
163   xfwm4-theme-wallis \  
164 "
165
166 XSERVER_BASE = " \
167   ${XSERVER} \
168   xf86-input-evtouch \
169   dbus-x11 \
170   desktop-file-utils \
171   iso-codes \
172   mime-support \
173   notification-daemon inotify-tools \
174   xauth \
175   xdg-utils \
176   xhost \
177   xinetd \
178   xinit \
179   xlsfonts \
180   xrdb \
181   xrefresh \
182   xset \
183   xvinfo \
184 "
185
186 RDEPENDS_${PN} = " \
187   task-pandora-core \
188   angstrom-x11-base-depends \
189   ${ANGSTROM_EXTRA_INSTALL} \
190   ${APPS} \
191   ${IM_CLIENT} \
192   ${DISPMAN} \
193   ${FONTS} \
194   ${GNOME_GTK} \
195   ${GNOME_APPS} \
196   ${GSTREAMER} \
197   ${ICON_THEME} \
198   ${PERL} \
199   ${PULSEAUDIO} \
200   ${TOTEM} \
201   ${XSERVER_BASE} \
202   ${XFCE46_BASE} \
203   ${XFCE46_EXTRAS} \
204   ${XFCE_THEMES} \
205   \
206 #       pandora-auto-startx \
207   pandora-first-run-wizard \
208   \
209   rxvt-unicode \
210   xst \
211   suspend-desktop \
212   teleport \
213   gdk-pixbuf-loader-png \
214   gdk-pixbuf-loader-xpm \
215   gdk-pixbuf-loader-jpeg \
216   pango-module-basic-x \
217   pango-module-basic-fc \
218   xcursor-transparent-theme \   
219   angstrom-zeroconf-audio \
220   angstrom-led-config \         
221   mime-support \
222   xterm xmms \
223   jaaa nmap iperf gnuplot \
224   x11vnc angstrom-x11vnc-xinit \
225 "