3ea17578492c26dc8dc3a41838c42b6b76fba069
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
1 DESCRIPTION = "Task file for the XFCE Pandora image"
2
3 # Don't forget to bump the PR if you change it.
4
5 PR = "r9"
6
7 inherit task
8
9 ANGSTROM_EXTRA_INSTALL ?= ""
10
11 APPS = " \
12   avahi-ui \
13   abiword \
14   claws-mail \
15   swfdec swfdec-gnome swfdec-mozilla \
16   firefox \
17   gnumeric \   
18 #  gimp \
19   networkmanager network-manager-applet \ 
20 #  synergy \
21   vnc x11vnc angstrom-x11vnc-xinit \
22   xchat \
23   xournal \
24 "
25
26 BLUETOOTH_GUI = " \
27   blueman \
28   gnome-bluetooth \
29 "
30
31 IM_CLIENT = " \
32   pidgin \
33   libpurple-protocol-msn \
34   libpurple-protocol-yahoo \
35   libpurple-protocol-icq \
36   libpurple-protocol-aim \
37 "
38
39 DISPMAN = " \
40   slim \
41   slim-op-themes \
42 "
43
44 FONTS = " \
45   font-adobe-75dpi \
46   fontconfig fontconfig-utils font-util \
47   ttf-arphic-uming \
48   ttf-dejavu-common \
49   ttf-dejavu-sans \
50   ttf-dejavu-serif \
51   ttf-dejavu-sans-mono \
52   ttf-liberation-sans \
53   ttf-liberation-serif \
54   ttf-liberation-mono \
55   xorg-minimal-fonts \
56 "  
57
58 # Any default games we want to ship.
59 GAMES = " \
60 #  scummvm \
61 #  frozen-bubble \
62 #  gnome-games \  
63 "
64
65 GNOME_APPS = " \
66   gnome-mplayer \
67 #  gcalctool \ 
68   gnome-keyring gnome-keyring-pam-plugin \
69   gksu \
70 "
71
72 GNOME_GTK = " \
73 #  gnome-icon-theme \
74 #  angstrom-gnome-icon-theme-enable \
75 "
76
77 GSTREAMER = " \
78 #  gstreamer-ti \
79   gst-ffmpeg \
80   gst-omapfb \
81 #  gst-plugin-pulse \
82   gst-plugin-xvimagesink \
83   gst-plugins-base-meta \
84   gst-plugins-good-meta gst-plugins-bad-meta \
85 #  gst-plugins-ugly-meta \
86   gst-plugin-gles \
87 "
88
89 ICON_THEME = " \
90   hicolor-icon-theme \
91   elementary-icon-theme \
92   elementary-icon-theme-enable \
93 "
94
95 LAUNCHERS = " \
96   netbook-launcher-efl \
97 "
98
99 PANDORA = " \
100   pandora-first-run-wizard hsetroot \
101   pandora-scripts \
102   pandora-wallpaper-official pandora-wallpaper-community \
103   pandora-xfce-defaults \
104   pandora-xmms-defaults xmms \
105   pandora-midori-defaults midori \
106   pandora-libpnd-minimenu \
107   pandora-pmenu \
108   libgles2d \
109 "
110
111 PERL = " \
112   perl \
113   task-perl-module-all \
114   libnet-dbus-perl \
115   libxml-parser-perl \
116   libxml-twig-perl \
117 "
118
119 PULSEAUDIO = " \
120 #  pulseaudio-alsa-wrapper \
121 #  pulseaudio-esd-wrapper \
122 #  pulseaudio-module-gconf \
123 #  libasound-module-ctl-pulse \
124 #  libasound-module-pcm-pulse \
125 "
126
127 QT_SELECTED = "qt4-x11-free-gles"
128 #  qt4-x11-free \
129
130 QT_SUPPORT = " \
131   ${QT_SELECTED} \
132 "
133
134 # We want all of the Qt metapackage (for dev use) without the demos/examples.
135 BAD_RRECOMMENDS += " \
136   ${QT_SELECTED}-demos \
137   ${QT_SELECTED}-examples \
138 "
139
140 TOTEM = " \
141   totem \
142   totem-browser-plugin \
143   totem-plugin-bemused \
144   totem-plugin-gromit \
145   totem-plugin-media-player-keys \
146   totem-plugin-ontop \
147   totem-plugin-properties \
148   totem-plugin-screensaver \
149   totem-plugin-skipto \
150   totem-plugin-thumbnail \
151 "
152
153 TOUCHSCREEN = " \
154   gtk-touchscreen-mode-enable \
155   libgtkstylus \
156   xinput-calibrator \
157 "
158
159 XFCE46_BASE = " \
160   xfce4-dev-tools \
161   xfwm4 \
162   xfwm4-theme-default \
163   xfce-utils \  
164   xfce4-session \     
165   xfconf \
166   xfdesktop \
167   xfce4-panel \
168   xfce4-power-manager \
169   \
170   gtk-xfce-engine \
171   \
172   xfce4-panel-plugin-actions \
173   xfce4-panel-plugin-clock \
174   xfce4-panel-plugin-iconbox \
175   xfce4-panel-plugin-launcher \
176   xfce4-panel-plugin-pager \
177   xfce4-panel-plugin-separator \
178   xfce4-panel-plugin-showdesktop \
179   xfce4-panel-plugin-systray \
180   xfce4-panel-plugin-tasklist \
181   xfce4-panel-plugin-windowlist \   
182   xfce4-settings \
183   xfce-terminal \
184   thunar \
185 "
186
187 XFCE46_EXTRAS = " \
188   xfce4-notifyd \
189   xfce4-mixer \
190   xfce4-appfinder \
191   xfce4-battery-plugin \
192   xfprint \    
193   orage \
194   squeeze \
195   ristretto \
196   mousepad \ 
197   gigolo \
198 "
199
200 XFCE_THEMES = " \
201   xfwm4-theme-daloa \
202   xfwm4-theme-moheli \
203 #  xfwm4-theme-default-4.0 \
204 #  xfwm4-theme-default-4.2 \
205 #  xfwm4-theme-default-4.4 \
206   xfwm4-theme-kokodi \
207   xfwm4-theme-sassandra \
208 #  xfwm4-theme-stoneage \
209 #  xfwm4-theme-therapy \
210 #  xfwm4-theme-tyrex \
211 #  xfwm4-theme-wallis \  
212   xfwm4-themes \
213 "
214
215 XSERVER_BASE = " \
216   ${XSERVER} \
217   dbus-x11 \
218   desktop-file-utils \
219   iso-codes \
220   mime-support \
221   notification-daemon inotify-tools \
222   xauth \
223   xdg-utils \
224   xhost \
225   xinetd \
226   xinit \
227   xlsfonts \
228   xrdb \
229   xrefresh \
230   xset \
231   xvinfo \
232   devilspie \
233   encodings \
234   xterm \
235   xmodmap \
236 "
237
238 RDEPENDS_${PN} = " \
239   task-pandora-core \
240   angstrom-x11-base-depends \
241   ${ANGSTROM_EXTRA_INSTALL} \
242   ${APPS} \
243   ${BLUETOOTH_GUI} \
244   ${IM_CLIENT} \
245   ${DISPMAN} \
246   ${FONTS} \
247   ${GAMES} \  
248   ${GNOME_GTK} \
249   ${GNOME_APPS} \
250   ${GSTREAMER} \
251   ${ICON_THEME} \
252   ${LAUNCHERS} \
253   ${PANDORA} \
254   ${PERL} \
255   ${PULSEAUDIO} \
256   ${QT_SUPPORT} \
257   ${TOTEM} \
258   ${TOUCHSCREEN} \
259   ${XSERVER_BASE} \
260   ${XFCE46_BASE} \
261   ${XFCE46_EXTRAS} \
262   ${XFCE_THEMES} \
263   \
264   rxvt-unicode \
265 #  xst \
266 #  suspend-desktop \
267 #  teleport \
268   gdk-pixbuf-loader-png \
269   gdk-pixbuf-loader-xpm \
270   gdk-pixbuf-loader-jpeg \
271   pango-module-basic-x \
272   pango-module-basic-fc \
273   xcursor-transparent-theme \   
274   xterm xmms \
275   jaaa nmap iperf \
276 #  gnuplot \
277 "