sg3-utils: add newer buildable version
[openembedded.git] / recipes / t1lib / t1lib_5.0.2.bb
1 DESCRIPTION = "A Type1 Font Rastering Library"
2 HOMEPAGE = "http://www.t1lib.org/"
3 SECTION = "libs"
4 PRIORITY = "optional"
5 DEPENDS = "virtual/libx11 libxaw"
6 PR = "r6"
7 LICENSE = "LGPL GPL"
8 SRC_URI = "${DEBIAN_MIRROR}/main/t/t1lib/t1lib_${PV}.orig.tar.gz \
9            file://configure.patch;patch=1 \
10            file://install.patch;patch=1 \
11            file://libtool.patch;patch=1"
12
13 inherit autotools
14
15 # Fix GNU_HASH problem
16 TARGET_CC_ARCH += "${LDFLAGS}"
17
18 EXTRA_OECONF = "--with-x --without-athena"
19 EXTRA_OEMAKE = "without_doc"
20
21 do_configure() {
22         rm -f ${S}/ac-tools/aclocal.m4
23         autotools_do_configure
24 }
25
26 FILES_${PN} += "${bindir}/* ${libdir}/*.so* ${datadir}/t1lib/t1lib.config"
27 FILES_${PN}-doc += "${datadir}/t1lib/doc/t1lib_doc.pdf"
28