sg3-utils: add newer buildable version
[openembedded.git] / recipes / stopwatch / stopwatch_1.4.0.bb
1 DESCRIPTION = "Simple Qt based stop watch"
2 AUTHOR = "Christof Musik"
3 SECTION = "x11/applications"
4 PRIORITY = "optional"
5 HOMEPAGE = "http://git.senfdax.de"
6 LICENSE = "GPL QPL"
7 PR = "r0"
8
9 inherit qt4x11
10
11 SRC_URI = "http://openmoko.senfdax.de/sources/${PN}-${PV}.tar.gz;name=archive"
12
13 SRC_URI[archive.md5sum] = "6cc756ea7a8fb94352eb2842d170f16c"
14 SRC_URI[archive.sha256sum] = "ef4fdbb3ab44e950a56c55e38dd5ffc449f736fb5d99d2befe5bbfc715bcb919"
15
16 do_configure() {
17     ${OE_QMAKE_QMAKE}
18 }
19
20 do_compile() {
21     oe_runmake
22 }
23
24 do_install() {
25     install -d ${D}/${bindir}
26     install -m 0755 ${S}/stopwatch ${D}/${bindir}
27     install -d ${D}/${datadir}/applications
28     install ${S}/desktop/stopwatch.desktop ${D}/${datadir}/applications/
29     install -d ${D}/${datadir}/pixmaps
30     install ${S}/desktop/stopwatch.png ${D}/${datadir}/pixmaps/
31     install -d ${D}/${datadir}/${PN}
32     install ${S}/desktop/om.style ${D}/${datadir}/${PN}/
33 }