psplash: Update to v1.70 (without RC)
[openembedded.git] / recipes / sparse / sparse_snapshot.bb
1 SECTION = "devel"
2 def get_snapshot_date(d):
3         import bb
4         srcdate = bb.data.getVar('SRCDATE', d, 1)
5         if not srcdate:
6                 return ""
7         y = srcdate[0:4]
8         m = srcdate[4:6]
9         d = srcdate[6:8]
10         return "%s-%s-%s" % (y, m, d)
11
12 DESCRIPTION = "Sparse is a semantic parser of source files: it's neither a \
13 compiler (although it could be used as a front-end for one) nor is it a \
14 preprocessor (although it contains as a part of it a preprocessing phase)."
15 PV = "0.0+${SRCDATE}"
16 LICENSE = "OSL"
17 SRC_URI = "http://www.codemonkey.org.uk/projects/git-snapshots/sparse/sparse-${@get_snapshot_date(d)}.tar.gz \
18            file://compile.patch;patch=1 \
19            file://vars.patch;patch=1"
20 S = "${WORKDIR}/sparse-bk"
21
22 do_install () {
23         install -d ${D}${bindir}
24         install -m 0755 check ${D}${bindir}/sparse
25 }