libgcrypt: restore BBCLASSEXTEND
[openembedded.git] / recipes / shr / shr-splash_git.bb
1 DESCRIPTION = "SHR splash screen"
2 SECTION = "x11/data"
3 LICENSE = "MIT BSD"
4 SRCREV = "0375bf2b66a053dd490774004c56b5d949f02ac8"
5 PV = "1.2+gitr${SRCREV}"
6 PR = "r5"
7 DEPENDS = "virtual/shr-splash-theme"
8 RRECOMMENDS = "virtual/shr-splash-theme"
9
10 inherit update-rc.d
11
12 SRC_URI = "git://git.shr-project.org/repo/shr.git;protocol=http;branch=master"
13
14 S = "${WORKDIR}/git/${PN}"
15
16 FILES_${PN} = "${datadir}/shr-splash \
17                ${sysconfdir}/init.d/shr-splash.sh \
18 "
19
20 do_install() {
21     install -d ${D}${datadir}/shr-splash
22     install -d ${D}${datadir}/shr-splash/themes
23     install -d ${D}${sysconfdir}/init.d
24
25     install -m 0755 ${S}/shr-splash.sh        ${D}${sysconfdir}/init.d/shr-splash.sh
26
27 }
28
29 pkg_postinst() {
30     [ -e ${datadir}/pixmaps/xsplash-vga.ppm ] || ln -s ${datadir}/shr-splash/theme/xsplash-vga.ppm ${datadir}/pixmaps/xsplash-vga.ppm
31 }
32
33
34 INITSCRIPT_NAME = "shr-splash.sh"
35 INITSCRIPT_PARAMS = "start 01 S . stop 21 0 1 6 ."