frameworkd-config-shr: move SRCREV to recipe
[openembedded.git] / recipes / shr / frameworkd-config-shr_git.bb
1 DESCRIPTION = "SHR Configuration for frameworkd"
2 HOMEPAGE = "http://www.freesmartphone.org"
3 AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de> et. al."
4 SECTION = "console/network"
5 DEPENDS = "python-cython-native python-pyrex-native"
6 LICENSE = "GPL"
7
8 SRCREV_pn-frameworkd-config-shr_FSO_REV ?= "f751f2724eea23d0ca050bdf2672f9011ae09517"
9 SRCREV_pn-frameworkd-config-shr_SHR_REV ?= "cdf5b5f3d8f37d6d91e1eb8d9cf07d034291df87"
10
11 SRCREV_FORMAT = "FSO_REV-SHR_REV"
12 PV = "0.9.5.9+gitr${SRCREV}"
13 PR = "r7"
14
15 SRC_URI = "${FREESMARTPHONE_GIT}/framework.git;protocol=git;branch=master;name=FSO_REV \
16            git://git.shr-project.org/repo/shr-themes.git;protocol=http;branch=master;name=SHR_REV"
17 S = "${WORKDIR}/git"
18
19 PROVIDES_${PN} = "frameworkd-config"
20 RPROVIDES_${PN} = "frameworkd-config"
21 CONF_PATH = "${S}/frameworkd/${PN}"
22
23 do_install_append() {
24         install -d ${D}${sysconfdir}
25         install -d ${D}${sysconfdir}/freesmartphone/opreferences/schema/
26         install -d ${D}${sysconfdir}/freesmartphone/opreferences/conf/profiles/
27         install -d ${D}${sysconfdir}/freesmartphone/opreferences/conf/phone/
28         install -d ${D}${sysconfdir}/freesmartphone/opreferences/conf/rules/
29         install -d ${D}${sysconfdir}/freesmartphone/oevents/
30         install -d ${D}${sysconfdir}/freesmartphone/ogsmd/
31         install -d ${D}${sysconfdir}/freesmartphone/persist/
32         install -d ${D}${sysconfdir}/freesmartphone/opim/
33         install -m 0644 ${S}/etc/freesmartphone/opreferences/schema/phone.yaml ${D}${sysconfdir}/freesmartphone/opreferences/schema/
34         install -m 0644 ${S}/etc/freesmartphone/opreferences/schema/profiles.yaml ${D}${sysconfdir}/freesmartphone/opreferences/schema/
35         install -m 0644 ${S}/etc/freesmartphone/opreferences/schema/rules.yaml ${D}${sysconfdir}/freesmartphone/opreferences/schema/
36         install -m 0644 ${S}/etc/freesmartphone/persist/README ${D}${sysconfdir}/freesmartphone/persist/
37         install -m 0644 ${S}/etc/freesmartphone/ogsmd/networks.tab ${D}${sysconfdir}/freesmartphone/ogsmd/
38         install -m 0644 ${S}/etc/freesmartphone/ogsmd/cell.db ${D}${sysconfdir}/freesmartphone/ogsmd/
39         install -m 0644 ${S}/etc/freesmartphone/ogsmd/la.db ${D}${sysconfdir}/freesmartphone/ogsmd/
40
41         #Check for machine specific conf.
42         CONF_PATH_MACHINE="${CONF_PATH}"
43         if [ -d "${CONF_PATH}/${MACHINE}" ] ; then
44                 CONF_PATH_MACHINE="${CONF_PATH}/${MACHINE}"
45         fi
46         # Install SHR custom files
47         install -m 0644 ${CONF_PATH_MACHINE}/frameworkd.conf ${D}${sysconfdir}
48         install -m 0644 ${CONF_PATH_MACHINE}/rules.yaml ${D}${sysconfdir}/freesmartphone/oevents/
49         install -m 0644 ${CONF_PATH}/profiles/profiles/default.yaml ${D}${sysconfdir}/freesmartphone/opreferences/conf/profiles/
50
51         install -m 0644 ${CONF_PATH}/profiles/phone/default.yaml ${D}${sysconfdir}/freesmartphone/opreferences/conf/phone/
52         install -m 0644 ${CONF_PATH}/profiles/rules/default.yaml ${D}${sysconfdir}/freesmartphone/opreferences/conf/rules/
53
54         install -m 0644 ${CONF_PATH}/profiles/phone/ring.yaml ${D}${sysconfdir}/freesmartphone/opreferences/conf/phone/
55         install -m 0644 ${CONF_PATH}/profiles/rules/ring.yaml ${D}${sysconfdir}/freesmartphone/opreferences/conf/rules/
56
57         install -m 0644 ${CONF_PATH}/profiles/phone/vibrate.yaml ${D}${sysconfdir}/freesmartphone/opreferences/conf/phone/
58         install -m 0644 ${CONF_PATH}/profiles/rules/vibrate.yaml ${D}${sysconfdir}/freesmartphone/opreferences/conf/rules/
59
60         install -m 0644 ${CONF_PATH}/profiles/phone/silent.yaml ${D}${sysconfdir}/freesmartphone/opreferences/conf/phone/
61         install -m 0644 ${CONF_PATH}/profiles/rules/silent.yaml ${D}${sysconfdir}/freesmartphone/opreferences/conf/rules/
62
63         install -d ${D}${datadir}/sounds
64         install -m 0644 ${CONF_PATH}/*.wav ${D}${datadir}/sounds/
65 }
66
67 PACKAGE_ARCH_${PN} = "${MACHINE_ARCH}"
68
69 # machine specific stuff, should ideally be elsewhere
70 # - recommend MUXer on platforms that require one
71 RDEPENDS_${PN}_append_om-gta01 = " fso-abyss"
72 RDEPENDS_${PN}_append_om-gta02 = " fso-abyss"
73 RDEPENDS_${PN}_append_om-3d7k  = " fso-abyss"
74 # - add wmiconfig for wireless configuration
75 RDEPENDS_${PN}_append_om-gta02 = " wmiconfig"
76
77 FILES_${PN} = "\
78   ${sysconfdir}/frameworkd.conf \
79   ${sysconfdir}/freesmartphone \
80   ${datadir}/sounds \
81 "
82 CONFFILES_${PN} = "\
83   ${sysconfdir}/frameworkd.conf \
84   ${sysconfdir}/freesmartphone/opreferences/conf/phone/silent.yaml \
85   ${sysconfdir}/freesmartphone/opreferences/conf/phone/default.yaml \
86   ${sysconfdir}/freesmartphone/opreferences/conf/profiles/default.yaml \
87   ${sysconfdir}/freesmartphone/opreferences/conf/rules/silent.yaml \
88   ${sysconfdir}/freesmartphone/opreferences/conf/rules/default.yaml \
89   ${sysconfdir}/freesmartphone/oevents/rules.yaml \
90   ${sysconfdir}/freesmartphone/ogsmd/networks.tab \
91 "