serial-utils: fetch updated versions from FSO git and bump sane-srcrevs
[openembedded.git] / recipes / serial-utils / pty-forward-native.bb
1 DESCRIPTION = "Receive a forwarded serial from serial-forward and provide a PTY"
2 AUTHOR = "Holger 'Zecke' Freyther"
3 LICENSE = "GPL"
4 SECTION = "console/network"
5 PV = "1.0.1+gitr${SRCREV}"
6 PR = "r0"
7
8 SRC_URI = "${FREESMARTPHONE_GIT}/cornucopia.git;protocol=git"
9 S = "${WORKDIR}/git/tools/serial_forward"
10
11 inherit native
12
13 do_compile() {
14     cd ${S}
15     oe_runmake
16 }
17
18 do_stage() {
19     :
20 }
21
22 do_deploy() {
23     install -d ${DEPLOY_DIR_IMAGE}
24     install -m 0755 ${S}/pty_forward ${DEPLOY_DIR_IMAGE}/pty-forward
25 }
26
27 addtask deploy before do_package after do_install