libgcrypt: restore BBCLASSEXTEND
[openembedded.git] / recipes / samba / samba_3.5.6.bb
1 require samba.inc
2 require samba-basic.inc
3 LICENSE = "GPLv3"
4 S = "${WORKDIR}/samba-${PV}/source3"
5
6 # 3.3.0 and newer will upgrade your tdb database to a
7 # new version that you can not downgrade to use with older
8 # releases. More testing will happen before this is removed
9 # should there be further issues. Appears to work though :)
10 #DEFAULT_PREFERENCE = "-1"
11
12 SRC_URI += "file://config-h.patch;patch=1 \
13             file://tdbheaderfix.patch;apply=no"
14
15 PR = "r1"
16
17 EXTRA_OECONF += "\
18         SMB_BUILD_CC_NEGATIVE_ENUM_VALUES=yes \
19         samba_cv_CC_NEGATIVE_ENUM_VALUES=yes \
20         linux_getgrouplist_ok=no \
21         samba_cv_HAVE_BROKEN_GETGROUPS=no \
22         samba_cv_HAVE_FTRUNCATE_EXTEND=yes \
23         samba_cv_have_setresuid=yes \
24         samba_cv_have_setresgid=yes \
25         samba_cv_HAVE_WRFILE_KEYTAB=yes \
26         samba_cv_linux_getgrouplist_ok=yes \
27         "
28
29 do_configure() {
30         # Patches we must apply by hand due to layout.
31         cd ..
32         patch -p1 -i ${WORKDIR}/tdbheaderfix.patch
33         cd source3
34
35         oe_runconf
36 }
37
38 do_compile () {
39         base_do_compile
40 }
41
42 SRC_URI[src.md5sum] = "bf6c09ea497a166df8bd672db1d8da8f"
43 SRC_URI[src.sha256sum] = "466410868375d19a286ac3fc5d9f3c267ce359189f8e0d76e72ec10bd54247da"