qt4-native: rename to qt4-tools-native
[openembedded.git] / recipes / qt4 / qt4-tools-native_4.4.3.bb
1 DESCRIPTION = "Native tools for Qt/[X11|Mac|Embedded] version 4.x"
2 DEPENDS = "zlib-native"
3 SECTION = "libs"
4 HOMEPAGE = "http://www.trolltech.com"
5 PRIORITY = "optional"
6 LICENSE = "GPL"
7 PR = "r0"
8
9 inherit native
10
11 SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-embedded-linux-opensource-src-${PV}.tar.bz2 \
12            file://qt-config.patch;patch=1" 
13 S = "${WORKDIR}/qt-embedded-linux-opensource-src-${PV}"
14
15 EXTRA_OECONF = "-prefix ${prefix} \
16                 -qt-libjpeg -qt-gif -system-zlib \
17                 -no-nis -no-cups -no-exceptions  \
18                 -no-accessibility -no-libjpeg    \
19                 -no-nas-sound -no-sm             \
20                 -no-xshape    -no-xinerama       \
21                 -no-xcursor   -no-xrandr         \
22                 -no-xrender   -no-fontconfig     \
23                 -no-tablet    -no-xkb            \
24                 -no-libpng                       \
25                 -verbose -release  -fast -static \
26                 -qt3support "
27 # yank default -e
28 EXTRA_OEMAKE = " "
29
30 do_configure() {
31     # Make sure we regenerate all Makefiles
32     find ${S} -name "Makefile" | xargs rm
33
34     sed -i 's:^QT += xml qt3support$:QT += xml qt3support network:' "${S}"/src/tools/uic3/uic3.pro
35     echo yes | ./configure ${EXTRA_OECONF} || die "Configuring qt failed. EXTRA_OECONF was ${EXTRA_OECONF}"
36 }
37
38 TOBUILD = "\
39   src/tools/moc \
40   src/corelib \
41   src/sql \
42   src/qt3support \
43   src/xml \
44   src/tools/uic \
45   src/tools/rcc \
46   src/network \
47   src/gui \
48   src/tools/uic3 \
49   tools/linguist/lrelease \
50   tools/linguist/lupdate \
51 "
52
53 do_compile() {
54     for i in ${TOBUILD}; do
55         cd ${S}/$i && oe_runmake CC="${CC}" CXX="${CXX}"
56     done
57 }
58
59 do_stage() {
60         install -d ${STAGING_BINDIR}/
61     install -m 0755 bin/qmake ${STAGING_BINDIR}/qmake2
62     ln -sf qmake2 ${STAGING_BINDIR}/qmake-qt4
63     for i in moc uic uic3 rcc lrelease lupdate; do
64         install -m 0755 bin/${i} ${STAGING_BINDIR}/${i}4
65     done
66     install -d ${STAGING_DATADIR_NATIVE}/qt4/
67     cp -PfR mkspecs ${STAGING_DATADIR_NATIVE}/qt4/
68     install -m 0644 tools/porting/src/q3porting.xml ${STAGING_DATADIR_NATIVE}/qt4/
69 }