psplash: Update to v1.70 (without RC)
[openembedded.git] / recipes / qmatrix / qmatrix_1.1.0.bb
1 DESCRIPTION = "A matrix Game, Qt/Embedded based Palmtop Environments Edition"
2 SECTION = "opie/games"
3 LICENSE = "GPL"
4 PRIORITY = "optional"
5 PR = "r2"
6
7 SRC_URI = "http://www.geocities.co.jp/SiliconValley-Oakland/8074/src/qmatrix-${PV}.tar.gz"
8 S = "${WORKDIR}/qmatrix"
9
10 inherit palmtop
11
12 MACHTYPE = "sl300"
13 MACHTYPE_c7x0    = "sl700"
14 MACHTYPE_tosa    = "sl700"
15
16 do_configure_append() {
17         ln -v -f -s config/config-${MACHTYPE}.h config.h
18         ln -v -f -s config/config.mk-${MACHTYPE} config.mk
19         if [ "${MACHTYPE}" = "sl300" ]
20         then
21                 ln -vfs bigFishSize.h areaSize.h
22         else
23                 ln -vfs smallFishSize.h areaSize.h
24         fi
25         ln -v -f -s HiScoreRegConfig-${MACHTYPE}.h HiScoreRegConfig.h
26 }
27
28 do_compile_prepend() {
29         cd images && oe_runmake && cd ${S}
30 }
31
32 do_install() {
33         install -d ${D}${palmtopdir}/apps/Games
34         install -m 0644 desktop/qmatrix-${MACHTYPE}.desktop ${D}${palmtopdir}/apps/Games/qmatrix.desktop
35         install -d ${D}${palmtopdir}/bin
36         install -m 0755 qmatrix ${D}${palmtopdir}/bin/qmatrix
37         install -d ${D}${palmtopdir}/pics
38         install -m 0644 desktop/qmatrix.png ${D}${palmtopdir}/pics/
39         install -d ${D}${palmtopdir}/help/html/
40         install -m 0644 desktop/qmatrix.html ${D}${palmtopdir}/help/html/qmatrix.html
41 }