psplash: Update to v1.70 (without RC)
[openembedded.git] / recipes / pthsem / pthsem_2.0.7.bb
1 DESCRIPTION = "GNU Portable Threads replacement with semaphore support"
2 SECTION = "libs"
3 PRIORITY = "optional"
4 LICENSE = "GPL LGPL FDL"
5 PR = "r0"
6
7 SRC_URI = "https://www.auto.tuwien.ac.at/~mkoegler/pth/pthsem-${PV}.tar.gz \
8            file://ldflags.patch;patch=1 \
9           "
10
11 inherit autotools binconfig
12
13 do_configure() {
14         gnu-configize
15         oe_runconf
16 }
17 do_install_prepend() {
18         cp ${S}/pth-config ${S}/pthsem-config
19 }
20 do_stage() {
21         oe_libinstall -so libpthsem ${STAGING_LIBDIR}
22         install -d ${STAGING_INCDIR}/
23         install -m 0644 ${S}/pth.h ${STAGING_INCDIR}/pthsem.h
24         install -d ${STAGING_BINDIR}/
25         install -d ${STAGING_DATADIR}/aclocal
26         install pth.m4 ${STAGING_DATADIR}/aclocal/pthsem.m4
27 }
28
29 BINCONFIG_GLOB = "pthsem-config"
30
31 PARALLEL_MAKE = ""