libgcrypt: update to 1.4.6
[openembedded.git] / recipes / poqetpresenter / poqetpresenter_0.0.6.bb
1 DESCRIPTION = "OpenOffice.org Impress presentation viewer for Qt/E based Palmtop environments"
2 SECTION = "opie/applications"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5 HOMEPAGE = "http://poqetp.sourceforge.net/"
6 PR = "r2"
7
8 SRC_URI = "${SOURCEFORGE_MIRROR}/poqetp/poqetp_${PV}_src.tar.gz"
9 S = "${WORKDIR}/poqetp"
10
11 inherit palmtop
12
13 do_configure_prepend() {
14         find . -name "Makefile"|xargs rm -f # force regenerating Makefiles
15 }
16
17 do_install() {
18         install -d ${D}${palmtopdir}/bin \
19                    ${D}${palmtopdir}/apps/Applications \
20                    ${D}${palmtopdir}/pics
21         install -D -m 0755 poqetp/poqetp ${D}${palmtopdir}/bin/poqetp
22         install -D -m 0644 poqetp.desktop ${D}${palmtopdir}/apps/Applications/poqetp.desktop
23         install -d ${D}${palmtopdir}/pics/poqetp
24         cp -pPR pics/* ${D}${palmtopdir}/pics/poqetp/
25 }