libgcrypt: restore BBCLASSEXTEND
[openembedded.git] / recipes / pdm / pdm_1.0.bb
1 SECTION = "x11/base"
2 LICENSE = "GPL"
3 DESCRIPTION = "pdm is a minimal session manager for GUIs."
4
5 SRC_URI="http://www.penguru.net/download/${PN}-${PV}.tar.gz \
6         file://pdm-1.0-changes.patch;patch=1 \
7         file://pdm.conf \
8         file://xfce \
9         file://mythtv"
10
11 do_install() {
12         install -d ${D}${sbindir} \
13                    ${D}${sysconfdir}/pdm/sessions \
14                    ${D}${sysconfdir}/pdm/plugins
15
16         install -m 0755 pdm ${D}${sbindir}/pdm
17         install -m 0644 conf/pdm.conf* ${D}${sysconfdir}/pdm/
18         install -m 0644 ${WORKDIR}/pdm.conf ${D}${sysconfdir}/pdm/
19         install -m 755 ${WORKDIR}/xfce ${D}${sysconfdir}/pdm/sessions/xfce
20         install -m 755 ${WORKDIR}/mythtv ${D}${sysconfdir}/pdm/sessions/mythtv
21 }