Merge branch 'org.openembedded.dev' of git@git.openembedded.org:openembedded into...
[openembedded.git] / recipes / openobex / openobex_1.3.bb
1 DESCRIPTION = "The Openobex project is an open source implementation of the \
2 Object Exchange (OBEX) protocol."
3 HOMEPAGE = "http://openobex.triq.net"
4 SECTION = "libs"
5 PROVIDES = "openobex-apps"
6 DEPENDS = "libusb bluez-libs"
7 LICENSE = "GPL"
8 PR = "r0"
9
10 SRC_URI = "${SOURCEFORGE_MIRROR}/openobex/openobex-${PV}.tar.gz \
11            file://disable-cable-test.patch;patch=1 \
12            file://libusb_crosscompile_check.patch;patch=1"
13
14 inherit autotools binconfig pkgconfig
15
16 EXTRA_OECONF = "--enable-apps --enable-syslog --enable-dump \
17                 --with-usb=${STAGING_LIBDIR}/.. --with-bluez=${STAGING_LIBDIR}/.."
18
19 do_stage() {
20         autotools_stage_all
21 }
22
23 # how to stop shlibrename from renaming -apps?
24 PACKAGES += "openobex-apps"
25 FILES_${PN} = "${libdir}/lib*.so.*"
26 FILES_${PN}-dev += "${bindir}/openobex-config"
27 FILES_${PN}-apps = "${bindir}/*"
28 DEBIAN_NOAUTONAME_${PN}-apps = "1"