elementary: readd RDEPENDS on elementary-themes, accidentally removed in 51d8c6927248...
[openembedded.git] / recipes / obexpush / obexpush_1.0.0.bb
1 DESCRIPTION = "Obex Push Utilities"
2 HOMEPAGE = "http://www.caside.lancs.ac.uk/java_bt.php"
3 SECTION = "console/network"
4 LICENSE = "GPL"
5 DEPENDS = "glib-2.0 openobex bluez-libs"
6 PR = "r6"
7
8 SRC_URI = "http://www.caside.lancs.ac.uk/bt/obexpush.tar.gz \
9            file://add-obextool.patch;patch=1 \
10            file://init \
11            file://opd_args"
12 S = "${WORKDIR}/obexpush"
13
14 inherit update-rc.d
15
16 INITSCRIPT_NAME = "opd"
17 INITSCRIPT_PARAMS = "defaults 33 09"
18
19 export GLIBINC = "-I${STAGING_INCDIR}/glib-2.0"
20 export GLIBLIB = "-I${STAGING_LIBDIR} -lglib-2.0"
21 export OBEXINC = "-I${STAGING_INCDIR}"
22 export OBEXLIB = "${LDFLAGS} -lopenobex"
23
24 do_configure() {
25         rm -f client/*.o client/ussp-push
26         rm -f opd/*.o opd/opd
27         sed -i 's:gcc:${CC}:' */Makefile
28         sed -i 's:__FUNCTION__::' opd/*.c
29 }
30
31 do_compile() {
32         oe_runmake -C client ussp-push
33         oe_runmake -C client obextool
34         oe_runmake -C opd
35 }
36
37 do_install() {
38         install -d ${D}${bindir}
39         install -d ${D}${sbindir}
40         install -m 0755 client/ussp-push ${D}${bindir}
41         install -m 0755 client/obextool ${D}${bindir}
42         install -m 0755 opd/opd ${D}${sbindir}
43
44         install -d ${D}${sysconfdir}/init.d
45         install -d ${D}${sysconfdir}/default
46         install -d ${D}/var/obexpush
47         install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/opd
48         install -m 0755 ${WORKDIR}/opd_args ${D}${sysconfdir}/default/opd_args
49 }
50