Merge branch 'org.openembedded.dev' of git.openembedded.org:openembedded into org...
[openembedded.git] / recipes / networkmanager / network-manager-applet_git.bb
1 DESCRIPTION = "GTK+ applet for NetworkManager" 
2 LICENSE = "GPL"
3 DEPENDS = "libnotify networkmanager dbus-glib libglade gconf gnome-keyring"
4 RDEPENDS = "networkmanager"
5
6 DEFAULT_PREFERENCE = "-1"
7
8 SRCREV = "efa170820623e7c1d6c161bfc8a37db0d074d09e"
9 PV = "0.7.1+git"
10 PR_append = ".gitr${SRCREV}"
11
12 inherit gnome
13
14 SRC_URI = "git://git.gnome.org/network-manager-applet;protocol=git;branch=NETWORKMANAGER_APPLET_0_7 \
15 file://nm-applet.conf"
16
17 S = "${WORKDIR}/git"
18
19 # Hack around dbus a_console problems
20 do_install_append() {
21         install -m 0644 ${WORKDIR}/nm-applet.conf ${D}${sysconfdir}/dbus-1/system.d/
22 }
23
24 FILES_${PN} += "${datadir}/nm-applet/ \
25         ${datadir}/gnome-vpn-properties/ \
26         ${datadir}/gnome/autostart/ \
27         "