psplash: Update to v1.70 (without RC)
[openembedded.git] / recipes / netsurf / netsurf_2.1.bb
1 DESCRIPTION = "Lightweight web browser capable of handling many of the \
2 web standards in use today."
3 HOMEPAGE = "http://www.netsurf-browser.org/"
4 SECTION = "x11/network"
5 LICENSE = "GPLv2"
6
7 SRC_URI = "http://www.netsurf-browser.org/downloads/releases/netsurf-${PV}-src.tar.gz \
8            file://fix_makefile.patch;patch=1 \
9            file://debugxml_fix.patch;patch=1 \
10            file://netsurf.png \
11            file://netsurf.desktop \
12            file://Makefile.config"
13
14 PR = "r1"
15
16 # Workaround for 2.1 tarball (unpacks into netsurf/, not netsurf-2.1/ )
17 S = "${WORKDIR}/netsurf"
18
19 DEPENDS = "gtk+ lemon-native re2c-native jpeg openssl curl libxml2 \
20            libglade hubbub libnsgif libnsbmp lcms"
21
22 EXTRA_OEMAKE = "CURDIR=${S} DESTDIR=${D} PREFIX=${prefix}"
23
24 do_configure() {
25         cp ${WORKDIR}/Makefile.config ${S}/
26 }
27
28 do_install() {
29         oe_runmake install
30         install -d ${D}/${datadir}/applications
31         install -d ${D}/${datadir}/pixmaps
32         install -m 0644 ${WORKDIR}/netsurf.png ${D}/${datadir}/pixmaps/
33         install -m 0644 ${WORKDIR}/netsurf.desktop ${D}/${datadir}/applications/
34 }