3c51a5fa3c5fe49b19213e8413dd22f1e69ea278
[openembedded.git] / recipes / net-snmp / net-snmp_5.4.2.1.bb
1 require net-snmp.inc
2
3 SRC_URI = "${SOURCEFORGE_MIRROR}/net-snmp/net-snmp-${PV}.tar.gz \
4         file://configure-tail.patch;patch=1 \
5         file://init \
6         file://snmpd.conf \
7         file://snmptrapd.conf"
8
9 EXTRA_OECONF = "--enable-shared --disable-manuals --with-defaults \
10                 --disable-embedded-perl --with-perl-modules=no"
11 EXTRA_OEMAKE = "INSTALL_PREFIX=${D}"
12
13 do_configure_prepend() {
14         gnu-configize -f
15         # We better change sources and re-autoconf here, but
16         # required autoconf is too new for us.
17         sed -e '/echo.*\".*\\\\.*\"/s/echo/echo -e/g' \
18             -e 's/tail -1/tail -n 1/g'                \
19             -i configure
20
21         #The tarball for v5.4.2.1 is missing config.sub
22         cp ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}
23 }
24
25 PARALLEL_MAKE = ""
26 CCACHE = ""