xfce4-battery-plugin: tune the pandora hack
[openembedded.git] / recipes / multitap-pad / multitap-pad_svn.bb
1 DESCRIPTION = "Multi-tap input method for GTK"
2 LICENSE = "GPL"
3 DEPENDS = "libfakekey gtk+ matchbox-panel-2"
4 RCONFLICTS = matchbox-keyboard-inputmethod
5 SECTION = "x11"
6 SRCREV = "373"
7 PV = "0.0+svnr${SRCPV}"
8
9 SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=${PN};proto=http \
10         file://80multitappad"
11
12 inherit autotools pkgconfig
13
14 S = "${WORKDIR}/${PN}"
15
16 FILES_${PN} = "${bindir}/* \
17                ${libdir} \
18                ${sysconfdir} \
19                ${datadir}"
20
21 FILES_${PN}-dbg += " ${libdir}/gtk-2.0/2.10.0/immodules/.debug \
22                      ${libdir}/matchbox-panel/.debug"
23
24 FILES_${PN}-dev += " ${libdir}/gtk-2.0/2.10.0/immodules/*.a \
25                      ${libdir}/gtk-2.0/2.10.0/immodules/*.la \
26                      ${libdir}/matchbox-panel/*.a \
27                      ${libdir}/matchbox-panel/*.la"
28
29 do_install_append () {
30         install -d ${D}/${sysconfdir}/X11/Xsession.d/
31         install -m 755 ${WORKDIR}/80multitappad ${D}/${sysconfdir}/X11/Xsession.d/
32 }
33
34 pkg_postinst_multitap-pad () {
35 if [ "x$D" != "x" ]; then
36   exit 1
37 fi
38
39 gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
40 }
41
42 pkg_postrm_multitap-pad () {
43 if [ "x$D" != "x" ]; then
44   exit 1
45 fi
46
47 gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
48 }