Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[openembedded.git] / recipes / mozilla / firefox_1.0.7.bb
1 PR = "r2"
2
3 SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/source/firefox-${PV}-source.tar.bz2 \
4         file://xptcstubs.patch;patch=1 \
5         file://no-xmb.patch;patch=1 \
6         file://firefox-cc-fix.patch;patch=1 \
7         file://jsautocfg.h \
8         file://extensions-hack.patch;patch=1 \
9         file://firefox-1.0-gcc4-compile.patch;patch=1;pnum=0 \
10         file://xptcinvoke-arm.patch;patch=1 \
11         file://mozilla-eabi.patch;patch=1"
12 S = "${WORKDIR}/mozilla"
13
14 inherit autotools mozilla
15         
16 require firefox.inc
17
18 EXTRA_OECONF += " --with-gssapi=${STAGING_LIBDIR}/../"
19
20 do_compile_prepend() {
21         cp ${WORKDIR}/jsautocfg.h ${S}/js/src/
22 }