libgcrypt: update to 1.4.6
[openembedded.git] / recipes / matchbox2 / matchbox-wm-2_svn.bb
1 DEPENDS = "gtk+ startup-notification dbus dbus-glib"
2 SRCREV = "2087"
3 PV = "0.1.0+svnr${SRCPV}"
4 PR = "r0"
5
6 SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=matchbox-window-manager-2;proto=http \
7            file://fix-timeout-handler-free.patch;patch=1 \
8            file://makefile-vars.patch;patch=1;pnum=0 \
9 "
10 S = "${WORKDIR}/matchbox-window-manager-2"
11
12 inherit autotools pkgconfig
13
14 # FIXME: --enable-glib-main-loop causes hard grab-freeze
15 EXTRA_OECONF = "--with-gtk --with-pango --enable-matchbox-remote --enable-png-theme --enable-maemo-manager"
16
17 do_install_append() {
18         mv ${D}${bindir}/matchbox-remote ${D}${bindir}/matchbox-remote-2
19         # Without libmatchbox there are no includes and no libraries, just empty directories:
20         rm -r ${D}${includedir} ${D}${libdir}
21 }
22
23 FILES_${PN} += "${datadir}/themes/*"