sg3-utils: add newer buildable version
[openembedded.git] / recipes / matchbox2 / matchbox-panel-2_svn.bb
1 DESCRIPTION = "matchbox-panel-2 is a lightweight dock (system tray) application based on Gtk+"
2 LICENSE = "GPLv2"
3 SECTION = "x11/panels"
4 DEPENDS = "gtk+ startup-notification dbus dbus-glib matchbox-panel-2-icon-themes"
5 DEPENDS += " ${@base_contains("MACHINE_FEATURES", "acpi", "libacpi", "",d)}"
6 DEPENDS += " ${@base_contains("MACHINE_FEATURES", "apm", "apmd", "",d)}"
7 RDEPENDS_${PN} = "matchbox-panel-2-icon-theme"
8 PACKAGE_ARCH = "${MACHINE_ARCH}"
9 SRCREV = "2098"
10 PV = "2.0+svnr${SRCPV}"
11 PR = "r1"
12
13 inherit autotools_stage pkgconfig
14
15 SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http \
16            file://scaling-image-double-free.patch;patch=1;pnum=0 \
17            file://startup-invalid-access.patch;patch=1;pnum=0 \
18            file://startup-shown-uninitialized.patch;patch=1;pnum=0 \
19            file://themeable-icons.patch;patch=1;pnum=0 \
20 "
21 S = "${WORKDIR}/${PN}"
22
23 TARGET_CFLAGS += "-Wno-error"
24
25 EXTRA_OECONF = "--disable-static --program-transform-name='s/$/-2/'"
26 EXTRA_OECONF += " ${@base_contains("MACHINE_FEATURES", "acpi", "--with-battery=acpi", "",d)}"
27 EXTRA_OECONF += " ${@base_contains("MACHINE_FEATURES", "apm", "--with-battery=apm", "",d)}"
28
29 do_install_append() {
30         rm ${D}${libdir}/matchbox-panel/lib*.*a
31 }
32
33 FILES_${PN} += "${libdir}/matchbox-panel/*.so"
34 FILES_${PN}-dbg += "${libdir}/matchbox-panel/.debug"