xfce4-battery-plugin: tune the pandora hack
[openembedded.git] / recipes / linux-libc-headers / linux-libc-headers_2.6.15.99.bb
1 require linux-libc-headers.inc
2
3 # This package is derived from the original linux-libc-headers at
4 #   http://ep09.pld-linux.org/~mmazur/linux-libc-headers/
5 # More specifically, llh-2.6.12.0 was patched up to 2.6.16-rc6 with
6 # the official linux patches (where applicable) and then fixed up just
7 # enough to build glibc-2.4. BEWARE!
8 #
9 # license note from the linux-libc-headers package:
10 #   Linux-libc-headers are derived from linux kernel headers. For license of a
11 #   particular header, check it's content, and if copyright notice isn't present,
12 #   standard linux kernel license applies.
13 # since we assume GPL for linux i think we can also assume it here
14 DEFAULT_PREFERENCE = "-1"
15 INHIBIT_DEFAULT_DEPS = "1"
16 PR = "r6"
17
18 SRC_URI = "http://ewi546.ewi.utwente.nl/OE/eabi/linux-libc-headers-${PV}.tar.bz2 \
19         file://keyboard.patch;patch=1 \
20         file://asm-arch-irqs.patch;patch=1 \
21         file://linux-netdevice.patch;patch=1 \
22         file://linux-netfilter_ipv4.patch;patch=1 \
23         file://linux-rtc.patch;patch=1 \
24         file://linux-videodev2.patch;patch=1 \
25         file://3477-1.patch;patch=1"
26
27 S = "${WORKDIR}/linux-libc-headers-${PV}"
28
29 do_configure () {
30         case ${TARGET_ARCH} in
31                 alpha*)   ARCH=alpha ;;
32                 arm*)     ARCH=arm ;;
33                 cris*)    ARCH=cris ;;
34                 hppa*)    ARCH=parisc ;;
35                 i*86*)    ARCH=i386 ;;
36                 ia64*)    ARCH=ia64 ;;
37                 mips*)    ARCH=mips ;;
38                 m68k*)    ARCH=m68k ;;
39                 powerpc*) ARCH=ppc ;;
40                 s390*)    ARCH=s390 ;;
41                 sh*)      ARCH=sh ;;
42                 sparc64*) ARCH=sparc64 ;;
43                 sparc*)   ARCH=sparc ;;
44                 x86_64*)  ARCH=x86_64 ;;
45         esac
46         if test !  -e include/asm-$ARCH; then
47                 oefatal unable to create asm symlink in kernel headers
48         fi
49         rm "include/asm"
50         cp -pPR "include/asm-$ARCH" "include/asm"
51         if test "$ARCH" = "arm"; then
52                 cp -pPR include/asm/arch-ebsa285 include/asm/arch
53         elif test "$ARCH" = "sh"; then
54                 cp -pPR include/asm/cpu-${TARGET_ARCH} include/asm/cpu || die "unable to create include/asm/cpu"
55         fi
56 }
57
58 do_install() {
59         install -d ${D}${includedir}
60         cp -pfLR include/linux ${D}${includedir}/
61         cp -pfLR include/asm ${D}${includedir}/
62         cp -pfLR include/asm-generic ${D}${includedir}/
63 }
64