linux kernels: linux is GPLv2, so specify that in LICENSE instead of generic 'GPL'
[openembedded.git] / recipes / linux / mainstone-kernel_2.6.18.bb
1 require linux.inc 
2
3 SECTION = "kernel"
4 DESCRIPTION = "Linux kernel for the Mainstone (PXA270 ref design)"
5 LICENSE = "GPLv2"
6 PR = "r2"
7
8 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.18.tar.bz2 \
9            file://flash-unlock.patch;patch=1;pnum=0 \
10            file://defconfig"
11
12 S = "${WORKDIR}/linux-2.6.18"
13
14 COMPATIBLE_HOST = 'arm.*-linux'
15
16 ARCH = "arm"
17
18 CMDLINE_CONSOLE ?= "ttyS0,115200n8"
19 #CMDLINE_ROOT = "root=/dev/slug rootfstype=ext2,jffs2 initrd=0x01000000,10M mem=32M@0x00000000"
20 #CMDLINE_ROOT = "root=/dev/ram0 rw rootfstype=ext2,jffs2 initrd=0x01000000,10M init=/linuxrc mem=32M@0x00000000"
21 CMDLINE_ROOT = "root=/dev/mtdblock2 rootfstype=jffs2 console=ttyS0,115200 mem=64M"
22 CMDLINE = "${CMDLINE_ROOT} ${CMDLINE_CONSOLE}"
23
24 COMPATIBLE_MACHINE = "mainstone"