linux 2.6.31: update to 2.6.31.7
[openembedded.git] / recipes / linux / linux_2.6.31.bb
1 require linux.inc
2
3 PR = "r7"
4
5 S = "${WORKDIR}/linux-${PV}"
6
7 # Mark archs/machines that this kernel supports
8 DEFAULT_PREFERENCE = "-1"
9 DEFAULT_PREFERENCE_boc01 = "1"
10 DEFAULT_PREFERENCE_collie = "1"
11 DEFAULT_PREFERENCE_db1200 = "1"
12 DEFAULT_PREFERENCE_qemumips = "1"
13 DEFAULT_PREFERENCE_qemux86 = "1"
14 DEFAULT_PREFERENCE_iei-nanogx-466 = "1"
15 DEFAULT_PREFERENCE_ben-nanonote = "1"
16
17
18 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
19            ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${PV}.7.bz2;patch=1 \
20            file://defconfig"
21
22 SRC_URI += "file://0001-Squashfs-move-zlib-decompression-wrapper-code-into.patch;patch=1 \
23             file://0002-Squashfs-Factor-out-remaining-zlib-dependencies-int.patch;patch=1 \
24             file://0003-Squashfs-add-a-decompressor-framework.patch;patch=1 \
25             file://0004-Squashfs-add-decompressor-entries-for-lzma-and-lzo.patch;patch=1 \
26             file://0005-Squashfs-add-an-extra-parameter-to-the-decompressor.patch;patch=1 \
27             file://0006-Squashfs-add-LZMA-compression.patch;patch=1 \
28             file://0007-Squashfs-Make-unlzma-available-to-non-initramfs-ini.patch;patch=1 \
29            "
30
31 SRC_URI_append_db1200 ="\
32             http://maxim.org.za/AT91RM9200/2.6/2.6.31-at91.patch.gz;patch=1 \
33             "
34
35 SRC_URI_append_boc01 = "\
36            http://maxim.org.za/AT91RM9200/2.6/2.6.31-at91.patch.gz;patch=1 \
37            file://boc01.dts \
38            file://boc01.dts.v1 \
39            file://004-081205-usb.patch;patch=1 \
40            file://005-091110-isl12024.patch;patch=1 \
41            file://007-091005-lm73.patch;patch=1 \
42            file://011-091028-gpio.patch;patch=1 \
43            file://012-091019-capsense.patch;patch=1 \
44            file://013-091015-lcd.patch;patch=1 \
45            file://014-091030-buttons.patch;patch=1 \
46            "
47
48 SRC_URI_append_collie = "\
49            file://0001-add-locomo_spi-driver.patch;patch=1 \
50            file://0002-collie-fix-scoop-convesion-to-new-api.patch;patch=1 \
51            file://0003-collie-prepare-for-gpiolib-use.patch;patch=1 \
52            file://0004-move-drivers-mfd-.h-to-include-linux-mfd.patch;patch=1 \
53            file://0005-collie-locomo-led-change-default-trigger.patch;patch=1 \
54            file://0006-SA1100-make-gpio_to_irq-and-reverse-a-macro.patch;patch=1 \
55            file://0007-add-gpiolib-support-to-ucb1x00.patch;patch=1 \
56            file://0008-collie-convert-to-gpiolib-for-ucb1x00.patch;patch=1 \
57            file://0009-collie-add-battery-driver.patch;patch=1 \
58            file://0010-collie-support-pda_power-driver.patch;patch=1 \
59            file://0011-fix-collie-keyboard-bug.patch;patch=1 \
60            file://0012-add-collie-touchscreen-driver.patch;patch=1 \
61            file://0013-add-sa1100-udc-hack-extra-hacked-for-collie.patch;patch=1 \
62            file://0014-gadget-add-file.patch;patch=1 \
63            file://0004-fix-dma-for-SA1100.patch;patch=1 \
64            "
65
66
67 SRC_URI_append_ep93xx = " \
68            file://edb9301-fix-machine-id.patch;patch=1 \
69            "
70
71 SRC_URI_append_ben-nanonote = " \
72            file://files.patch;patch=1 \
73            file://001-core.patch;patch=1 \
74            file://050-nand.patch;patch=1 \
75            file://051-fb.patch;patch=1 \
76            file://052-rtc.patch;patch=1 \
77            file://053-adc.patch;patch=1 \
78            file://100-battery.patch;patch=1 \
79            file://101-mmc.patch;patch=1 \
80            file://102-video.patch;patch=1 \
81            file://103-lcm.patch;patch=1 \
82            file://103-serial.patch;patch=1 \
83            file://104-usb.patch;patch=1 \
84            file://105-sound.patch;patch=1 \
85            file://220-add-2gb-nand-support.patch;patch=1 \
86            file://300-jffs2-summery-vmalloc.patch;patch=1 \
87            file://400-spi-gpio-3wire.patch;patch=1 \
88            file://410-soc-32bit-regs.patch;patch=1 \
89            file://500-modifier-keys.patch;patch=1 \
90            file://900-add-openwrt-logo.patch;patch=1 \
91            file://fix_mips_vmlinux.lds.patch;patch=1 \
92            "
93
94 do_devicetree_image_append_boc01() {
95         dtc -I dts -O dtb ${KERNEL_DEVICETREE_FLAGS} -o devicetree.v1 ${KERNEL_DEVICETREE}.v1
96         install -m 0644 devicetree.v1 ${D}/boot/devicetree-${KERNEL_VERSION}.v1
97 }
98
99 pkg_postinst_kernel-devicetree_append_boc01 () {
100         cd /${KERNEL_IMAGEDEST}; update-alternatives --install /${KERNEL_IMAGEDEST}/devicetree.v1 devicetree.v1 devicetree-${KERNEL_VERSION}.v1 ${KERNEL_PRIORITY} || true
101 }
102
103 pkg_postrm_kernel-devicetree_append_boc01 () {
104         cd /${KERNEL_IMAGEDEST}; update-alternatives --remove devicetree.v1 devicetree-${KERNEL_VERSION}.v1 || true
105 }
106