linux-2.6.29: Stylize, use spaces not tabs.
[openembedded.git] / recipes / linux / linux_2.6.26.bb
1 require linux.inc
2
3 PR = "r8"
4
5 # Mark archs/machines that this kernel supports
6 DEFAULT_PREFERENCE = "-1"
7 DEFAULT_PREFERENCE_boc01 = "1"
8 DEFAULT_PREFERENCE_mpc8313e-rdb = "1"
9 DEFAULT_PREFERENCE_canyonlands = "1"
10
11 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.26.tar.bz2 \
12            file://defconfig"
13
14 SRC_URI_append_boc01 = "\
15         file://boc01.dts \
16         file://fsl-elbc-nand-backport.patch;patch=1 \
17         file://002-081105-headers.patch;patch=1 \
18         file://004-081105-usb.patch;patch=1 \
19         file://005-081217-isl12024.patch;patch=1 \
20         file://006-081216-at24c32.patch;patch=1 \
21         file://007-081216-lm73.patch;patch=1 \
22         file://008-081127-spi.patch;patch=1 \
23         file://010-081105-mii.patch;patch=1 \
24         file://011-081202-gpio.patch;patch=1 \
25         file://012-081222-cy3218-btns.patch;patch=1 \
26         file://013-081212-lcd.patch;patch=1 \
27         "
28
29 SRC_URI_append_mpc8313e-rdb = "\
30         file://cdc-ether-hack.patch;patch=1 \
31         file://fsl-elbc-nand-backport.patch;patch=1 \
32         file://mpc8313e-rdb-leds.patch;patch=1 \
33         file://mpc8313e-rdb-cardbus.patch;patch=1 \
34         file://mpc8313e-rdb-eth-fixed.patch;patch=1 \
35         "
36
37 # see http://bugzilla.kernel.org/show_bug.cgi?id=11143
38 do_stage_append() {
39         if [ -f arch/${ARCH}/lib/crtsavres.o ]; then
40                 mkdir -p ${STAGING_KERNEL_DIR}/arch/${ARCH}/lib
41                 cp -a arch/${ARCH}/lib/crtsavres.o ${STAGING_KERNEL_DIR}/arch/${ARCH}/lib/
42         fi
43 }
44