linux-2.6.24: fix kernel oops upon driver unload for hipox machine
[openembedded.git] / recipes / linux / linux_2.6.21.bb
1 require linux.inc
2
3 DEFAULT_PREFERENCE = "-1"
4 DEFAULT_PREFERENCE_at91sam9263ek = "-1"
5 DEFAULT_PREFERENCE_gumstix-connex = "1"
6 DEFAULT_PREFERENCE_gumstix-verdex = "1"
7
8 PR = "r13"
9
10 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
11            ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${PV}.7.bz2;patch=1 \
12            file://tsc2003.c \
13            file://tsc2003-config.diff;patch=1 \
14            file://defconfig \
15            "
16
17 SRC_URI_append_simpad = "\
18            file://linux-2.6.21-SIMpad-cs3-simpad.patch;patch=1 \
19            file://linux-2.6.21-SIMpad-mq200.patch;patch=1 \
20            file://linux-2.6.21-SIMpad-serial-gpio_keys-and-cs3-ro.patch;patch=1 \
21            file://linux-2.6.21-SIMpad-ucb1x00-switches.patch;patch=1 \
22            file://linux-2.6.21-SIMpad-pcmcia.patch;patch=1 \
23            file://linux-2.6.21-SIMpad-net-shared-irq.patch;patch=1 \
24            file://linux-2.6.21-SIMpad-ucb1x00-ts-supend-and-accuracy.patch;patch=1 \
25            file://linux-2.6.21-SIMpad-GPIO-MMC-mod.patch;patch=1 \
26            file://linux-2.6.21-SIMpad-battery-old-way-but-also-with-sysfs.patch;patch=1 \
27            file://linux-2.6.21-SIMpad-usb-gadget.patch;patch=1 \
28            "
29 SRC_URI_append_kb9202 = " http://maxim.org.za/AT91RM9200/2.6/2.6.21-at91.patch.gz;patch=1 "
30 SRC_URI_append_at91sam9263ek = " http://maxim.org.za/AT91RM9200/2.6/2.6.21-at91.patch.gz;patch=1 "
31 SRC_URI_append_sarge-at91 = " http://maxim.org.za/AT91RM9200/2.6/2.6.21-at91.patch.gz;patch=1 \
32                               file://2.6.21-sarge-kernel.patch;patch=1 \
33                               file://2.6.21-sarge-phy.patch;patch=1 \
34                               file://2.6.21-sarge-mmc.patch;patch=1"
35
36 GUMSTIX_PATCHES = "\
37        file://pxa-regs-additions.patch;patch=1 \
38        file://header.patch;patch=1 \
39        file://arch-config.patch;patch=1 \
40        file://board-init.patch;patch=1 \
41        file://compact-flash.patch;patch=1 \
42        file://flash.patch;patch=1 \
43        file://pxa2xx_udc.patch;patch=1 \
44        file://bkpxa-pxa-cpu.patch;patch=1 \
45        file://bkpxa-pxa-cpufreq.patch;patch=1 \
46        file://proc-gpio.patch;patch=1 \
47        file://serial-ether-addr.patch;patch=1 \
48        file://cpufreq-better-freqs.patch;patch=1 \
49        file://ethernet-config.patch;patch=1 \
50        file://smc-ether-addr.patch;patch=1 \
51        file://cpufreq-ondemand-by-default.patch;patch=1 \
52        file://modular-init-bluetooth.patch;patch=1 \
53        file://modular-init-smc91x.patch;patch=1 \
54        file://modular-init-usb-gadget.patch;patch=1 \
55        file://bugfix-i2c-include.patch;patch=1 \
56        file://bugfix-mmc-clock.patch;patch=1 \
57        file://bugfix-pxa-cpufreq.patch;patch=1 \
58        file://bugfix-serial-interrupt.patch;patch=1 \
59        file://bugfix-serial-register-status.patch;patch=1 \
60        file://mach-types-fix.patch;patch=1 \
61        file://pcm-gcc-411-bugfix.patch;patch=1 \
62        file://ucb1400-ac97-audio.patch;patch=1 \
63        file://gumstix-asoc.patch;patch=1 \
64        file://disable-uncompress-message.patch;patch=1 \
65        file://serial-divisor.patch;patch=1 \
66        file://mmc-card-detect.patch;patch=1 \
67        file://misalignment-handling.patch;patch=1 \
68        file://compile-fix-pxa_cpufreq.patch;patch=1 \
69        file://pxafb-definition.patch;patch=1 \
70        file://270-usb-gadget-udc.patch;patch=1 \
71        file://gumstix-pxa270-usb-host.patch;patch=1 \
72        file://cpufreq-fixup.patch;patch=1 \
73        file://uImage-in-own-partition.patch;patch=1 \
74        file://pxa-regs-fixup.patch;patch=1 \
75        file://gumstix-fb-logo.patch;patch=1 \
76        file://gumstix-pxa270-mmc.patch;patch=1 \
77        ${RPSRC}/pxa27x_overlay-r5.patch;patch=1 \
78        file://smc911x-fixup.patch;patch=1 \
79        "
80
81 SRC_URI_append_gumstix-verdex = "${GUMSTIX_PATCHES}"
82 SRC_URI_append_gumstix-connex = "${GUMSTIX_PATCHES}"
83
84
85 do_configure_prepend() {
86         cp ${WORKDIR}/tsc2003.c ${S}/drivers/i2c/chips/
87 }