Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[openembedded.git] / recipes / linux / linux-openmoko-2.6.24_git.bb
1 require linux.inc
2 require linux-openmoko.inc
3
4 DESCRIPTION = "The Linux kernel for the Openmoko devices GTA01 (Neo1973) and GTA02 (Neo FreeRunner)"
5
6 KERNEL_RELEASE = "2.6.24"
7 KERNEL_VERSION = "${KERNEL_RELEASE}"
8
9 OEV = "oe5"
10 PV = "${KERNEL_RELEASE}-${OEV}+gitr${SRCREV}"
11 PR = "r1"
12
13 SRC_URI = "\
14   git://git.openmoko.org/git/kernel.git;protocol=git;branch=stable \
15   \
16   file://0001-squashfs-with-lzma.patch;patch=1 \
17   file://0002-squashfs-initrd.patch;patch=1 \
18   file://0003-squashfs-force-O2.patch;patch=1 \
19   file://0004-squashfs-Kconfig.patch;patch=1 \
20   file://0005-squashfs-Makefile.patch;patch=1 \
21   \
22   file://openwrt-ledtrig-netdev.patch;patch=1 \
23   file://gta01-fix-battery-class-name.patch;patch=1 \
24   \
25   file://defconfig-oe \
26 "
27 S = "${WORKDIR}/git"