linux-2.6.29: Stylize, use spaces not tabs.
[openembedded.git] / recipes / linux / linux-omap_git.bb
1 require linux.inc
2
3 DESCRIPTION = "Linux kernel for OMAP processors"
4 KERNEL_IMAGETYPE = "uImage"
5
6 COMPATIBLE_MACHINE = "omap5912osk|omap1710h3|omap2430sdp|omap2420h4|beagleboard|omap3evm|omap3-pandora|overo"
7
8 # This is missing the EHCI patch for beagle
9 DEFAULT_PREFERENCE = "-1"
10
11
12 SRCREV = "90e758af52ba803cba233fabee81176d99589f09"
13
14 #PV = "2.6.29+2.6.30-rc1+${PR}+gitr${SRCREV}"
15 PV = "2.6.29-${PR}+gitr${SRCREV}"
16 PR = "r0"
17
18 SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/tmlind/linux-omap-2.6.git;protocol=git \
19            file://defconfig"
20
21 SRC_URI_append = " \
22            file://no-empty-flash-warnings.patch;patch=1 \
23            file://no-cortex-deadlock.patch;patch=1 \
24            file://read_die_ids.patch;patch=1 \
25            file://fix-install.patch;patch=1 \
26            file://DSS2.diff;patch=1 \
27 "
28
29
30 SRC_URI_append_beagleboard = " file://logo_linux_clut224.ppm \
31                              "
32
33 SRC_URI_append_omap3evm = " \
34         file://evm-mcspi-ts.diff;patch=1 \
35 "
36
37 S = "${WORKDIR}/git"
38
39
40 module_autoload_ohci-hcd_omap5912osk = "ohci-hcd"
41
42