omap3517-evm: omap3517 was the pre-production name, AM3517 is the production name...
[openembedded.git] / recipes / linux / linux-omap-psp_2.6.31.bb
1 require linux.inc
2
3 DESCRIPTION = "Linux kernel for OMAP processors"
4 KERNEL_IMAGETYPE = "uImage"
5
6 COMPATIBLE_MACHINE = "omap3evm|am3517-evm"
7
8 SRCREV = "9cf7a18fe227717dcc08163100dacd579de48e0c"
9
10 PV = "2.6.30+2.6.31rc7"
11 # The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc
12 PR_append = "+gitr${SRCREV}"
13
14 SRC_URI = "git://arago-project.org/git/people/sriram/ti-psp-omap.git;protocol=git;branch=staging \
15            file://0001-implement-TIF_RESTORE_SIGMASK-support-and-enable-the.patch;patch=1 \
16            file://defconfig"
17
18 S = "${WORKDIR}/git"
19
20 do_install_append() {
21         install -d ${D}/boot
22         install -m 0644 Documentation/arm/OMAP/DSS ${D}/boot/
23 }
24
25 PACKAGES =+ "omap-dss-doc"
26 FILES_omap-dss-doc = "/boot/DSS"
27
28