linux-2.6.24: fix kernel oops upon driver unload for hipox machine
[openembedded.git] / recipes / linux / linux-mini2440_2.6.30+git.bb
1 DESCRIPTION = "Linux Kernel for mini2440 development board"
2 SECTION = "kernel"
3 LICENSE = "GPL"
4 MACHINE_KERNEL_PR = "r5"
5
6 GGSRC = "http://www.xora.org.uk/oe/patches/"
7
8 SRCREV = "${AUTOREV}"
9
10 SRC_URI = "git://repo.or.cz/linux-2.6/mini2440.git;protocol=git;branch=mini2440-stable-v2.6.30 \
11            file://defconfig-mini2440"
12
13 S = "${WORKDIR}/git"
14
15 inherit kernel
16
17 COMPATIBLE_HOST = "arm.*-linux"
18 COMPATIBLE_MACHINE = "(mini2440|micro2440)"
19
20 FILES_kernel-image = ""
21 ALLOW_EMPTY_kernel_image = "1"
22
23 do_configure() {
24         install ${WORKDIR}/defconfig-mini2440 ${S}/.config
25         oe_runmake oldconfig
26 }
27
28 KERNEL_RELEASE = "2.6.30"