linux-2.6.24: fix kernel oops upon driver unload for hipox machine
[openembedded.git] / recipes / linux / linux-jlime-jornada7xx_2.6.32+git.bb
1 SECTION = "kernel"
2 DESCRIPTION = "JLime Linux kernel for Arm based Jornada 7xx"
3 LICENSE = "GPL"
4 PR = "r0"
5
6 COMPATIBLE_HOST = "arm.*-linux"
7 COMPATIBLE_MACHINE = "jornada7xx"
8
9 SRC_URI = "file://defconf_jlime"
10
11 S = "${WORKDIR}/linux-hpc"
12
13 inherit kernel
14
15 ARCH = "arm"
16
17 FILES_kernel-image = "/boot/${KERNEL_IMAGETYPE}*"
18
19 do_fetch () {
20         cd ${WORKDIR}
21         [ -d linux-hpc ] && {
22                 cd linux-hpc
23                 git pull
24         } || {
25                 git clone git://git.kernel.org/pub/scm/linux/kernel/git/kristoffer/linux-hpc.git
26                 cd linux-hpc
27                 # written individual do_fetch function because I don't know how to do this in SRC_URI:
28                 git-checkout --track -b v2.6.32-hpc origin/v2.6.32-hpc
29                 git-checkout v2.6.32-hpc
30         }
31 }
32
33 do_configure_prepend() {
34         install -m 0644 ${WORKDIR}/defconf_jlime ${S}/.config
35 }