Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[openembedded.git] / recipes / linux / linux-jlime-jornada7xx_2.6.18.bb
1 SECTION = "kernel"
2 DESCRIPTION = "JLime Linux kernel for Arm based Jornada 7xx"
3 LICENSE = "GPLv2"
4 PR = "r0"
5
6 COMPATIBLE_HOST = "arm.*-linux"
7 COMPATIBLE_MACHINE = "jornada7xx"
8
9 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.18.tar.gz \
10            file://defconf_jlime \
11            file://linux-2.6.18-jornada7xx.patch;patch=0"
12
13 S = "${WORKDIR}/linux-${PV}"
14
15 inherit kernel
16
17 #Lets let 3.4.x handle the compilation of this one
18 KERNEL_CCSUFFIX = "-3.4.4"
19
20 ARCH = "arm"
21 FILES_kernel-image = "/boot/${KERNEL_IMAGETYPE}*"
22
23 do_configure_prepend() {
24         install -m 0644 ${WORKDIR}/defconf_jlime ${S}/.config
25 }