Merge branch 'org.openembedded.dev' of ssh://git.openembedded.net/openembedded into...
[openembedded.git] / recipes / linux / linux-amsdelta-2.6_2.6.16-omap2.bb
1 SECTION = "kernel"
2 DESCRIPTION = "2.6 Linux kernel for the Amstrad Delta (E3)"
3 LICENSE = "GPLv2"
4
5 COMPATIBLE_MACHINE = "amsdelta"
6
7 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.16.tar.bz2 \
8         http://www.muru.com/linux/omap/patches/patch-2.6.16-omap2.bz2;patch=1 \
9         http://the.earth.li/pub/e3/2.6.16/00-ams-delta-backlight.diff;patch=1 \
10         http://the.earth.li/pub/e3/2.6.16/01-ams-delta-lcd.diff;patch=1 \
11         http://the.earth.li/pub/e3/2.6.16/02-ams-delta-keypad.diff;patch=1 \
12         http://the.earth.li/pub/e3/2.6.16/03-ams-delta-modem.diff;patch=1 \
13         http://the.earth.li/pub/e3/2.6.16/04-omapfb-12bpp-support.diff;patch=1 \
14         http://the.earth.li/pub/e3/2.6.16/05-ams-delta-nand.diff;patch=1 \
15         http://the.earth.li/pub/e3/2.6.16/06-ams-delta-keyboard.diff;patch=1 \
16         http://the.earth.li/pub/e3/2.6.16/08-ams-delta-sound.diff;patch=1 \
17         file://defconfig"
18 S = "${WORKDIR}/linux-2.6.16"
19
20 inherit kernel
21
22 python __anonymous () {
23     import re
24     host = bb.data.getVar('HOST_SYS', d, 1)
25     if not re.match('arm.*-linux', host):
26         raise bb.parse.SkipPackage("incompatible with host %s" % host)
27 }
28
29 KERNEL_IMAGETYPE = "uImage"
30
31 do_configure_prepend() {
32         install -m 0644 ${WORKDIR}/defconfig ${S}/.config
33         oe_runmake oldconfig
34 }